Issue 19962 - lack of indication of character styles on the object bar
Summary: lack of indication of character styles on the object bar
Status: CLOSED DUPLICATE of issue 29364
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1 RC4
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-09-24 01:31 UTC by Unknown
Modified: 2004-12-09 21:05 UTC (History)
2 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-09-24 01:31:53 UTC
Although paragraph styles you choose are indicated on the object bar, character
styles are not indicated there, and you have no way to know what character style
you applied unless you remember it. This is inconvenient, especially when you
want to change character styles later.
Comment 1 mci 2003-09-24 12:59:18 UTC
reassigned to bh
Comment 2 toralf 2003-10-04 11:16:23 UTC
Shouldn't there be a selection menu for character styles, too?

In fact, for some applications, I would like this to replace the font
and attribute selection, so that the user would *always* have to use a
well-defined style.
Comment 3 toralf 2003-10-04 15:48:56 UTC
I've been thinking a bit more about this, and I think character style
selection should definitely be on the toolbar - in the form of a
option menu, and perhaps also buttons (symmetric to the ones for
"bold", "italic" etc.) to select that will typically change
attributes, not typeface or font size, like e.g. "Emphasis". If this
makes the toolbar too crowded, consider removing font selection.

The point is, using styles instead of "manual" formatting is a good
practice that should be encouraged. The current GUI encourages the
manual approach instead, as the direct font and text attribute update
functionality is more reachabe to the user.
Comment 4 fousage 2004-08-08 15:09:03 UTC
And should it be possible to type in a character style name either to :
* select a defined and displayed (used) style,
* select a defined but hidden (unused) style,
* create a new style from selection.
with suggestion of existing styles to avoid unwanted style creation ?

TIA
Comment 5 toralf 2004-12-09 11:54:16 UTC
I also think that a better indication of deviations from styles, and also a
direct way to "unapply" them, would be nice. I'm talking about cases where:
- A certain paragraph style has been selected, then the appearance of the text
updated via font or attribute selection.
- As above, but using a character style instead.
- A paragraph style, then a character style, then a specific font or effect has
been selected.

In other words, the GUI should somehow indicate e.g. in the "current font"
display whether the font is active because it is the default font of the current
style, or because it was selected by the user. Also, when the font is
user-selected, there should be a direct way of "reverting" to the style's font.

This is somewhat related to issue 11792.
Comment 6 lohmaier 2004-12-09 21:05:02 UTC
I'll mark this as duplicate of issue 29364. Please transfer your votes.
Sorry for the inconvenience.

(I keep issue 29364 because it is shorter, contains the request in the initial
comment -> saves confusion/saves time reading and already has comments by
developers) 

*** This issue has been marked as a duplicate of 29364 ***
Comment 7 lohmaier 2004-12-09 21:05:28 UTC
closing duplicate.
Please transfer your votes.