Issue 20008 - Turn OFF auto-correction of capitalization by default
Summary: Turn OFF auto-correction of capitalization by default
Status: CLOSED DUPLICATE of issue 78661
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.1
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-09-24 21:57 UTC by drworley
Modified: 2007-07-02 13:50 UTC (History)
1 user (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description drworley 2003-09-24 21:57:03 UTC
This issue is based on OpenOffice version 1.0.1, as distributed with Red Hat
Linux 8.0, with updates to 22-Sep-2003.

When entering text into a cell, oocalc by default normalizes the capitalization
to having the first letter capitalized and all further letters lower-case.
Reading the issues database, this is apparently the intended behavior.
However, it is Very Surprising to the naive user and it is Inconvenient, and
it is entirely Non-Obvious how to defeat this behavior.

(For reference, go to Tools->AutoCorrect->Options, then un-check "Correct TWo
INitialCApitals" and "Capitalize first letter of every sentence".  I discovered
this only by searching the issues database, which is not adequate for non-expert
users.)

While this may appear to be a trivial matter, I have been recently making a
spreadsheet of names and addresses of companies, and a considerable number
of Internet-related companies have names that start with lower-case letters,
and use upper-case letters internally.  By default, oocalc incorrectly
normalizes both of these, making it impossible to feed the correct names into
a mail-merge program.

It may be useful to retain the capitalization-normalization feature as an
option, but it should by no means be the default, as it leads to behavior
that surprises the naive user.

(Note that the main competitor does not normalize capitalization.)
Comment 1 frank 2003-09-25 09:33:03 UTC
Hi Bettina,

1 4 u

Frank

Comment 2 brianblandford 2004-05-27 10:46:47 UTC
See similar issues 6493, 21735, 23612
Comment 3 drworley 2004-05-27 23:21:04 UTC
I've installed version 1.1.1 for Linux, which I think wipes out my
customizations.  This problem seems to have gone away, Calc is no longer
auto-correcting capitalization.
Comment 4 avagula 2006-11-02 18:19:21 UTC
Can someone take this? Autocapitalzation is still on by default. I hardly can
imagine an user who needs this in spreadsheet application.
Comment 5 frank.loehmann 2007-07-02 13:50:10 UTC
FL>78661

*** This issue has been marked as a duplicate of 78661 ***
Comment 6 frank.loehmann 2007-07-02 13:50:57 UTC
Closed