Issue 20055 - Q-PCD Provide a standard toolbar behavior
Summary: Q-PCD Provide a standard toolbar behavior
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: Other Other OS
: P2 Trivial (vote)
Target Milestone: OOo 2.0
Assignee: christian.jansen
QA Contact: issues@framework
URL:
Keywords:
: 11366 20053 21879 (view as issue list)
Depends on:
Blocks: 20121
  Show dependency tree
 
Reported: 2003-09-25 13:53 UTC by christian.jansen
Modified: 2004-12-28 10:36 UTC (History)
1 user (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description christian.jansen 2003-09-25 13:53:06 UTC
Product Requirement:
Toolbars should behave more intuitive and care about standards in toolbar design.

Product Concept:
The current toolbar concept will be reworked from scratch. We get rid of the
limitation that a toolbar occupies the entire width of the application window.
Instead toolbars are just as long as necessary to keep their controls. The
unused space in the toolbar area can be used to hold other toolbars. Toolbars
can be rearranged by dragndrop. If the context of the application changes new
toolbars might show up. We provide a smart handling of toolbars to close them
automatically if they are no longer needed. We have to consider the tradeoff
between a consistent UI and toolbars that come and go as they like.  Q offers an
easy to approach mode to customize the toolbar displays, e.g. small icons, large
icons, large icons with text labels. The order of the  toolbar controls can be
rearranged by using drag & drop.

Functional Specification:
http://specs.openoffice.org/ui_in_general/toolbars/openoffice_org_toolbar_spec.sxw
Comment 1 christian.jansen 2003-09-25 15:47:49 UTC
Accepted.
Comment 2 christian.jansen 2003-09-26 07:50:18 UTC
Additional Info:

Source
Users

Category
Toolbars / Icons

Eng Effort
HI

Eng Owner
Christian Jansen
Comment 3 matthias.mueller-prove 2003-10-15 18:05:41 UTC
*** Issue 20053 has been marked as a duplicate of this issue. ***
Comment 4 lutz.hoeger 2003-10-23 07:43:58 UTC
added keyword Q-PCD
Comment 5 bettina.haberer 2003-10-23 09:13:15 UTC
*** Issue 11366 has been marked as a duplicate of this issue. ***
Comment 6 bettina.haberer 2004-01-30 16:02:14 UTC
*** Issue 18129 has been marked as a duplicate of this issue. ***
Comment 7 christian.jansen 2004-03-25 09:02:14 UTC
Hi Elizabeth, the spec is ready for review:
please find it here:
http://specs.openoffice.org/ui_in_general/toolbar_concept/openoffice_org_toolbar_spec.sxw
Thanks!
Comment 8 thorsten.martens 2004-03-31 12:58:48 UTC
.
Comment 9 e.matthis 2004-03-31 13:11:00 UTC
on my to do list, planned to be done by April 16
Comment 10 e.matthis 2004-04-23 15:46:06 UTC
Thanks for the updates and help. rev done. changes per mail
Comment 11 matthias.mueller-prove 2004-05-12 18:15:56 UTC
this belongs to CWS docking1 and toolbars1
Comment 12 christian.jansen 2004-07-05 10:35:36 UTC
CJ -> We have to do lots of fine tuning, but I set this task to fixed to assure
that the feature can be integrated into the ömaster.
Comment 13 christian.jansen 2004-07-05 10:37:06 UTC
.
Comment 14 christian.jansen 2004-07-05 10:37:58 UTC
.
Comment 15 christian.jansen 2004-07-05 10:38:19 UTC
.
Comment 16 tomaisoc 2004-07-20 14:20:27 UTC
*** Issue 21879 has been marked as a duplicate of this issue. ***
Comment 17 christian.jansen 2004-12-28 10:34:16 UTC
I've verified this in m67 and it is OK. Closed.
Comment 18 christian.jansen 2004-12-28 10:36:03 UTC
I've verified this in m67 and it is OK. Closed.