Issue 20226 - Replacement of "new line" or "enter" not possible
Summary: Replacement of "new line" or "enter" not possible
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1 RC5
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-09-27 04:24 UTC by Unknown
Modified: 2007-04-18 19:54 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-09-27 04:24:01 UTC
Need:
A feature often needed other word processors is the following:
- Remove excessive "new lines" after pasting text from application x. Typically 
a web page or a text based e-mail.
- The need to replace all instances of two successive "new lines" with a single 
new line; or similar replacements.

Issue:
- OpenOffice does not allow that or that feature is not documented. The 
documentation mentions the \n character under the "regular expressions" search, 
but this does not solve this need. This \n is apparently for the "ctrl+enter".
- Openoffice also documents the \xXXXX to find a special character based on its 
four-digit hexadecimal code (XXXX). This does not solve the need either 
since "insert special character" does not include "enter".


(BTW: This is my *only* reason why I still feel I have keep a MS wordprocessor 
on my system.)

- Proposed solution: phase one: Just apply the search for "enter" and the 
replacement with "enter". phase two: Verify typical replament needs in this 
area offered by other word processors and apply them in OO.

Regards
Bart
Comment 1 mci 2003-10-30 18:07:20 UTC
reassigned to bh
Comment 2 guido.pinkernell 2004-02-12 10:54:44 UTC
blouwagie, please try the following excerpt from the faq whether it solves your
need:

=== faq ===

Follow these steps:

    *      Select Edit -> Find & Replace
    *      Near the bottom left of the dialog that appears, click on the box
next to "Regular Expressions"
    *      In the "Search For" field, type: ^$ This regular expression says to
search for a paragraph marker '$' at the beginning of a paragraph - programmer
terms for an empty paragraph.
    *      Click on the "Find" button
    *      To replace the hard return with a space character, type a space in
the "Replace With" field, then click the "Replace" button
    *      To replace the hard return with nothing (remove the character), click
the "Replace" button (without entering anything in the "Replace With" field)
    *      If you have many hard returns to replace, you can also use the
"Replace All" button. It is wise to save your document prior to using this
option, in case it behaves unexpectedly.

Note: Regular expressions do not appear to work in the 'Replace' field.
Comment 3 ace_dent 2007-04-18 19:54:08 UTC
Closing off issue- lack of activity.
User experience may be improved through Issue 10160.
Comment 4 ace_dent 2007-04-18 19:54:49 UTC
.