Issue 21113 - ms word doc file causes openoffice to hang
Summary: ms word doc file causes openoffice to hang
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1
Hardware: PC All
: P2 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
Keywords: crash, ms_interoperability, oooqa
Depends on:
Reported: 2003-10-13 10:36 UTC by zefo
Modified: 2013-08-07 14:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

gzipped ms word file (56.76 KB, application/octet-stream)
2003-10-13 10:37 UTC, zefo
no flags Details
smaller example (26.50 KB, application/octet-stream)
2003-10-29 09:22 UTC, caolanm
no flags Details
various OOo 1.1.1a crash/hang issue (3.24 MB, application/octet-stream)
2003-12-29 04:26 UTC, utomo99
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description zefo 2003-10-13 10:36:58 UTC
seems as an infinite loop
reproduced both on Win98 and Mandrake Linux 9.0
Comment 1 zefo 2003-10-13 10:37:34 UTC
Created attachment 10255 [details]
gzipped ms word file
Comment 2 zefo 2003-10-13 10:37:59 UTC
working fine with 1.0.3
Comment 3 utomo99 2003-10-13 10:40:19 UTC
I can Reproduce the problem on 
OpenOffice 1.1 (default Install, US), Win XP Pro Sp1. 
(And MS Office XP Sp2). 
It is real problem

cannot open the doc file using OOo, wait for loong time. 

Change OS to All, reproduce in Win XP
Comment 4 h.ilter 2003-10-13 10:51:32 UTC
Reassigned to MRU
Comment 5 michael.ruess 2003-10-13 12:08:01 UTC
MRU->FME: Loops right after import. Due to the fact that it worked in
1.0.3, it should be fixed for 1.1.1.
Comment 6 Oliver Specht 2003-10-22 14:25:02 UTC
This is not a P1 -> see
Comment 7 frank.meies 2003-10-29 08:27:14 UTC
FME->CMC: There are some assertions from the import filter. Could you
please have a look?
Comment 8 caolanm 2003-10-29 09:22:06 UTC
Created attachment 10740 [details]
smaller example
Comment 9 caolanm 2003-10-29 09:22:21 UTC
Tables in tables.
Comment 10 caolanm 2003-10-29 13:58:03 UTC
Ok, only take the positioning of the outer table into consideration
when putting the toplevel table into a floating frame.

Fixed for 2.0 in portlaoisefilterteam16 and for 1.1.1 in
Comment 11 caolanm 2003-11-07 15:52:54 UTC
reopen to reassign
Comment 12 caolanm 2003-11-07 15:53:36 UTC
cmc->mru: Good in Fri-Nov-07-16-00 portlaoisefilterteam16 installset
for 2.0, 1.1.1 installset will appear later
Comment 13 michael.ruess 2003-11-10 09:58:54 UTC
Checked fix with CWS portlaoisefilterteam16 for OOO 2.0 build. CWS &
Test for OO 1.1.1 will follow soon.
Comment 14 michael.ruess 2003-11-19 09:49:48 UTC
Verified. Fix will be included in OO 2.0.
Comment 15 caolanm 2003-12-03 13:47:37 UTC
cmc->mru: Working in droghedafilterteam15
Comment 16 michael.ruess 2003-12-05 15:59:14 UTC
Also verified in OO 1.1.1 workspace.
Comment 17 utomo99 2003-12-29 04:26:28 UTC
Created attachment 12161 [details]
various OOo 1.1.1a crash/hang issue
Comment 18 utomo99 2003-12-29 04:30:44 UTC
utomo > CMC & MRU:
It look like we are facing many crash/hang issue, and not yet solved totally. 
I test OOo 1.1.1a using my attached documents it still creating crash/hang. 
please investigate.

Comment 19 michael.ruess 2004-01-21 15:27:15 UTC
Having "hangs" after opening MS Word files are mostly all of different reasons.
These are mainly due to the individual structure of the document and happen
while formatting and building up the view of the document and do not refer to
the import filter. The original issue here is a kind of exception and is to be
found in the import filter.
Please submit single issues for the problems you find. Thanks!
Comment 20 michael.ruess 2004-01-27 15:58:08 UTC
Closed. Fix will be included in OO 1.1.1. checked with build srx645m27.