Issue 21299 - bug with horizontal line
Summary: bug with horizontal line
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1
Hardware: PC Windows 2000
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords: oooqa
: 21435 21717 25513 39711 47058 54395 74507 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-10-16 08:36 UTC by norbert2
Modified: 2014-09-11 00:10 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Documents to reproduce. I also want to note that found with WinXP, not 2000. Wrong selection. (17.53 KB, application/octet-stream)
2003-10-16 08:38 UTC, norbert2
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description norbert2 2003-10-16 08:36:46 UTC
I found a editing bug in the writer:

Please do the following steps to reproduce it:

1. Open a new, empty writer document.
2. Insert a horizontal line, the first simple on in the selection-window 
(attached document 1)
3. Set the cursor to the most upper/left position (pressing the arrow-up key 
should be enough :-) )
4. Press <Del>: Now you can see that it is impossible to delete the line! 
(attached document 2)
6. Insert any text above the line.
7. Press Return: You can see that the line does not move with the inserted 
text! (attached document 3)

	8. Another problem:
	attached document 4 contains such a line copied out of a .doc-file.
	You can see that it looks different to the one generated by oOO. But I 
find no way to edit the properties of such a line.
Comment 1 norbert2 2003-10-16 08:38:17 UTC
Created attachment 10357 [details]
Documents to reproduce. I also want to note that found with WinXP, not 2000. Wrong selection.
Comment 2 lohmaier 2003-10-16 12:39:51 UTC
the simple rule is just an empty paragraph with a paragraph-style with
border applied to it.
So to get rid of it either apply another paragraph-format (using the
stylist or the drop-down box in the toolbar) or insert a new paragraph
after the line, move it up before the horizontal line
(<ctrl>+<alt>+<arrow-up>) and then delete the paragraph with the line
using delete.
(the latter is also the solution for your second problem: you can
either move the line down <ctrl>+<alt>+<arrow-down> or an other
paragraph up <ctrl>+<alt>+<up>)

The line copied from the other doc is a paragraph-border as well (but
in this case it is not a paragraph-style but a hard-formatting)
To remove the line remove the hard-fomat by setting the paragraph back
to the style using Format|Default (or context-menu->default) or choose
Format|Paragraph->Borders to remove or edit the border.

->worksforme
Comment 3 lohmaier 2003-10-16 12:41:44 UTC
closing issue.
Comment 4 jack.warchold 2003-10-20 10:48:16 UTC
*** Issue 21435 has been marked as a duplicate of this issue. ***
Comment 5 lohmaier 2003-10-26 12:06:51 UTC
*** Issue 21717 has been marked as a duplicate of this issue. ***
Comment 6 lohmaier 2004-11-17 00:21:27 UTC
*** Issue 25513 has been marked as a duplicate of this issue. ***
Comment 7 michael.ruess 2005-01-03 08:09:58 UTC
*** Issue 39711 has been marked as a duplicate of this issue. ***
Comment 8 lohmaier 2005-04-09 23:38:30 UTC
*** Issue 47058 has been marked as a duplicate of this issue. ***
Comment 9 lohmaier 2005-09-15 23:49:10 UTC
*** Issue 54395 has been marked as a duplicate of this issue. ***
Comment 10 lohmaier 2005-11-06 00:55:09 UTC
*** Issue 57267 has been marked as a duplicate of this issue. ***
Comment 11 lohmaier 2005-11-08 22:57:40 UTC
*** Issue 57267 has been marked as a duplicate of this issue. ***
Comment 12 Regina Henschel 2007-02-13 20:31:44 UTC
*** Issue 74507 has been marked as a duplicate of this issue. ***
Comment 13 nidi 2007-11-01 02:21:29 UTC
This is definitely buggy behavior which needs to be fixed. There are many people
having problems with this.

At least, stop activating such borders by typing "---" (by default) or replace
it with some <hr> thing.

So please, act! Isn't there a company behind it which is interested in
customers, Sun? Dare to change things!
Comment 14 floid 2008-02-27 17:33:27 UTC
I see that there have been many issues filed regarding these behaviors, together
with the 'merge' / 'paragraph group' behavior described in issue #17758.

This is a real problem for users now that many websites / web services (Yahoo!
Mail in particular for my workplace, and various blog engines) are using
advertising services where links are created with <span> elements.  OO.o is
smart enough to interpret pasted HTML but turns the <span> into an unwanted
horizontal border that normal users can't remove and which can be 'tricky' even
for an advanced user, see below.

This is certainly less-loved than, e.g., Clippy.  I second nicodietrich's
comment and would even support a bounty (if one existed) to address the issue.  
Obviously I would like a fix that makes it easier to remove the border element
after the document has been edited and undo or dramatic reformatting are not
options.

There are a number of possible fixes at the various points where problems occur:

<span> elements could be interpreted differently in pasted HTML.
The UI could be more proactive about 'potentially confusing' pastes (How many
users intend to paste HTML?  How many know 'Paste Special' exists?)

Some form of UI could be added to make paragraph groups and 'style merging' more
obvious.  This itself is not a fix but may lead to more determinism (for
instance, in my experience selecting many paragraphs and disabling borders only
continues pushing the border north, even into territory where I the user am not
sure if the same paragraph style holds).

'Special case' versus 'style' formatting could equally be made more obvious or
brought into the UI in some fashion.

As of 2.0.2, it seems like the grouping behavior is either buggy or just
unfathomable with regard to large blocks that have received special-case
formatting.  It does seem like there needs to be both a 'Style settings' UI (as
exists) and an 'Object inspector' UI (to allow users to 'debug' what actually
exists in the document), rather than trying to guess at where properties like
borders have been set / are being inherited from.

Having a sort of vertical 'Styles' ruler, indicating where paragraph style
'blocks' begin or end, might also be useful, but the problem of the border
property forever inheriting up to the next 'block' (imagine dealing with this
from the signature area at the bottom of a 90 page document all the way to the
top) needs its own fix.
Comment 15 alfa333 2010-02-07 21:08:53 UTC
Hello! Please, reopen: Deleting a horizotal line unintentionally inserted is 
too difficult and can make a new user give up using OOo.

First a proposed solution, next the explanation of the problem (which is known, 
I believe).
When the user tries to delete such a line in "normal" ways, i.e. using Delete 
or Backspace or Edit-Cut, with the cursor near the line, then OOoWriter might 
display either a dialog "Do you want to remove the line? Y/N" or a hint 
like "If you want to remove the line, position the cursor just above the line 
and do "Format>Paragraph>...". OK". These dialog windows should contain also a 
box "Don't show me this message again", or better "Don't show me this message 
within [ ] nearest days" (to fill [ ] with a number) - so that the same or 
another user of this computer would have a chance to see the message.
The window should also show a text like "When you will want to reactivate such 
window(s), go to ..." (and this text should be visible BEFORE the user decides 
not to see the message ever again - I have never set such a box in any product, 
because I am not sure I will be able to change my mind in future).

The problem (discussed in the issues marked duplicates of this one): 
A horizontal line (considered a paragraph border) appears if I type three or 
more minus signs (or *,=,~,# signs) and Enter. The method to delete it IS in 
the help, but it is hard to find (and it does not work for old documents - do 
you want me to attach one, .odt?); and the user can be too confused to look at 
Help. 
(I'm using OOo 3.1.1 OOO310m19, WinXP Pro SP2.)

With best regards, alfa333
Comment 16 Bret Curry 2014-09-11 00:10:50 UTC
i was also unable to delete the line on a blank page