Issue 21365 - Internet Explorer 6.0 cant Open word docs using OO1.1
Summary: Internet Explorer 6.0 cant Open word docs using OO1.1
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 1.1
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-10-17 15:31 UTC by Unknown
Modified: 2013-08-07 15:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Word doc. w/screen capture of error messages (24.20 KB, text/plain)
2003-10-20 14:55 UTC, Unknown
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-10-17 15:31:42 UTC
Internet Explorer 6.0 cant Open word docs using OO1.1. We are piloting Open 
Office as possible replacement for MS Office. On of the problems we have 
discovered is that when OO is installed as the only Office Suite on Win2k/NT 
when we attempt to browse to docs on our intranet we cannot open them because 
Internet Explorer and Open Office dont talk to each other. The erro message we 
get is as follows:

"OpenOffice.org 1.1.0
http://staffnet/Managers/Training.xls:
General Internet error has occured."

When we click the "OK" button we receive the following error:
"Error
An API call exited abnormally."
Comment 1 con.hennessy 2003-10-20 12:00:06 UTC
Can you tell us if OpenOffice is running at the time ? 
Also is the error message in an Internet Explorer dialog window or an OpenOffice.org 
dialog window ? 
Comment 2 Unknown 2003-10-20 14:45:15 UTC
The first error message (Error loading document http://staffnet...) 
is an OpenOffice dialog box. The 2nd error (An API call exited 
abnormally.) is a generic dialog box (No inidictaion if its IE6 or 
OO1.1).

Thanks
Comment 3 Unknown 2003-10-20 14:55:51 UTC
Created attachment 10493 [details]
Word doc. w/screen capture of error messages
Comment 4 utomo99 2003-10-28 11:02:27 UTC
changing the component to framework (?) CMIIW from test
Comment 5 utomo99 2003-10-28 11:44:44 UTC
Reassign issue to owner of selected subcomponent
Comment 6 Unknown 2003-11-02 00:42:12 UTC
I have the exact same issue with OOo 1.1 and windows xp. But then i 
get a 403 forbidden message (where sdoherty got "General Internet 
error has occured.") The api message is the same. With ms-word it 
tends to open the .doc file in the internet explorer window itself 
and i have no problem.
Comment 7 thorsten.martens 2003-11-10 12:46:05 UTC
TM->sdoherty: Please check, if OOo´s own document-types (eg. *.sxw)
can be loaded within IE6. If they can´t, the active-X control wasn´t
installed (or wasn´t installed properly) during OOo´s setup. So start
setup again and choose the modify option. Select the active-X Plugin
to be installed and afterwards restart IE6. Our own document types
should be loaded without problems. For doing the same with MS-Office
documents, the appropiate checkboxes for opening those document-types
with OO must be checked during setup.

Loading documents via http will work, via https won´t ! 
Comment 8 thorsten.martens 2003-12-12 13:23:29 UTC
Problem wasn´t reproducible. Additional info after last comment wasn´t given ->
issue is set to "worksforme".
Comment 9 thorsten.martens 2004-03-19 14:31:34 UTC
.