Issue 22032 - Cannot insert non-Latin characters with Legendum font
Summary: Cannot insert non-Latin characters with Legendum font
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 1.1
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: OOo 1.1.1
Assignee: ulf.stroehler
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-11-02 19:32 UTC by Unknown
Modified: 2004-01-29 19:50 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Legendum font (76.82 KB, application/octet-stream)
2003-11-02 19:41 UTC, Unknown
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-11-02 19:32:49 UTC
With the Legendum font I cannot insert other characters than Basic Latin and
Latin-1 using OpenOffice.org 1.1. I don't have such a problem with other fonts.
Greek characters are displayed fine, but cannot be introduced using the “Insert
special character” option.
Comment 1 Unknown 2003-11-02 19:41:20 UTC
Created attachment 10890 [details]
Legendum font
Comment 2 jack.warchold 2003-11-06 15:53:14 UTC
reassigend to jw
Comment 3 jack.warchold 2003-11-20 17:16:18 UTC
i can confirm this behaviour on winxp with OOo1.1

the dialog insert -> special character does not show the non latin 
symbols of this font.

if i look in the character table of this font on xp start - > programs 
-> accessoiries -> system tools -> character i can see that this font 
does have a loot greek and other non latin characters

set to new 
set target to OOo 2.0
not reassigned because i need info from the developer if this is realy 
a bug of OOo
Comment 4 jack.warchold 2003-11-24 14:22:08 UTC
reassigned to hdu
Comment 5 hdu@apache.org 2003-11-25 09:34:13 UTC
The problem with the Legendum font is that it has two unicode CMAP
subtables which are incompatible. The first table says that the font
only supports U+0020..U+00F5, the second table has all the codes.

The best solution would be to fix the Legendum font to have consistent
CMAP subtables. The second best solution is a workaround for this font
problem by prefering CMAP 3.1 subtables over 1.0 subtables, because
the 3.1 ones are usually tested on more systems.
Comment 6 Unknown 2003-11-25 10:07:30 UTC
I don't think the font has two Unicode mapping tables; rather, the
Macintosh Roman table (1,0) is a format 4 table (and not format 0,
which is the expected thing to happen). An Apple Unicode encoding
would have (0,0) or (0,3). See
<http://developer.apple.com/fonts/TTRefMan/RM06/Chap6name.html>

Microsoft fonts like Verdana also have both a (1,0) and a (3,1) table
with the (1,0) table containing a smaller range. I don't think the
table format should be a factor in deciding which table to use.
Comment 7 hdu@apache.org 2003-11-25 13:43:32 UTC
Darn, you are right. I'm retargeting it to 1.1.1.
Comment 8 hdu@apache.org 2003-11-25 14:26:12 UTC
Fixed in CWS vcl7pp1r4.
Comment 9 hdu@apache.org 2003-12-18 14:57:23 UTC
HDU->MRU: Please verify in CWS vcl7pp1r4.
Comment 10 michael.ruess 2003-12-18 15:13:04 UTC
Please take over, as long as it your expert area and also your CWS. Thanks.
Comment 11 ulf.stroehler 2004-01-07 17:15:12 UTC
Fix verified on MS Windows.
Needs maintainance for Un*x. Will file follow-up.
Comment 12 ulf.stroehler 2004-01-07 17:17:57 UTC
Issue VERIFIED.
Comment 13 ulf.stroehler 2004-01-22 17:26:13 UTC
Re-verified on resynced vcl7pp1r4.
Comment 14 ulf.stroehler 2004-01-29 19:50:42 UTC
ok in (internal) master workspace srx645_m27s1-1.8738.
Fix will be in forthcomming OOo 1.1.1.
Closing Fixed/Verified issue.