Issue 22082 - Session cookies not sent when embedded in MSIE
Summary: Session cookies not sent when embedded in MSIE
Status: CONFIRMED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 1.1 RC5
Hardware: PC Windows ME
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
: 69102 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-11-03 22:46 UTC by aziem
Modified: 2017-05-20 10:55 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
screenshots of problem (77.31 KB, application/octet-stream)
2003-11-12 22:37 UTC, aziem
no flags Details
screenshot (57.50 KB, application/octet-stream)
2003-11-21 00:52 UTC, aziem
no flags Details
"You must be logged into SM" (145.00 KB, application/octet-stream)
2003-12-01 21:03 UTC, aziem
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description aziem 2003-11-03 22:46:32 UTC
OOo has some extension to view documents in Internet Explorer, but it isn't 
working for me.  There are two cases.

First there is one accessing SquirrelMail on the local network.  I click on an 
OOo attachment, and the new window is SquirelMail reporting that I'm not logged 
in.  I think this is because OOo should use IE's cookie to get the attachment 
URL.

The second case is on an external web site 
(http://europa.eu.int/ISPO/ida/jsps/index.jsp?
fuseAction=showDocument&parent=news&documentID=1647)  I am trying to open the 
OOo document, but OOo says it can't contact the site.  The situation is most 
likely that OOo isn't using IE's define proxy settings, and because port 80 is 
firewalled, the proxy is the only way out.

Thanks.
Comment 1 aziem 2003-11-03 22:57:22 UTC
Nevermind about the second case.  The first time OOo reported that it 
could not contact the host.  Now it loads the documents, though I 
didn't change anything.
Comment 2 diane 2003-11-07 03:02:30 UTC
You can associate which program is used to open each file type by
right clicking on a file in the explorer, then select Open With, and
then select the program you want to open that file. There should also
be a box there that you can click to select whether you always want
files of the same type to open with the same program. It sounds like
some of there file associations are not set up on your machine. The
OOo files should be associated to OOo. You can choose whether to
associate your msoffice files (DOC, XLS, PPT) to msoffice or to OOo.
Does this help?

Comment 3 aziem 2003-11-07 16:09:42 UTC
I believe OOo is correctly associated with files. 
* In the Windows Explorer, all XLS, DOC, SXW, SXC files show OOo
icons, and clicking on any of them starts OOo.
* In SquirrelMailin Internet Explorer, clicking on an OOo message
attachment starts OOo.  I can see the OOo window embedded in Internet
Explorer.  (There is the distinctive OOo menu bar.)

Previously I had DOC, XLS associated with MS Office.  When I clicked
on these file types in SquirrelMail, they would also open embedded in
Internet Explorer.

I think the problem is OOo is not using IE's session cookie to fetch
the attachment from SquirrelMail.  OOo's windows shows SM complaining
that I'm not logged in.  I can e-mail you a screen shot or the HTTP
log file, if you want.
Comment 4 diane 2003-11-08 13:42:53 UTC
A screen shot or log file may be helpful; although, step-by-step list
of instructions to reproduce the error would be the most helpful
information you could provide. Will you please add a list of steps here?
Comment 5 aziem 2003-11-12 22:37:40 UTC
Created attachment 11203 [details]
screenshots of problem
Comment 6 aziem 2003-11-12 22:41:51 UTC
I ran OpenOffice repair on my PC, and am having a new but related 
problem.  (So I can't get the original problem to recreate.)

Now OO does not load.  Instead I just get an icon where the OOO 
document should be.

Attachment shows screenshots of problem.  The second is what happens 
after I click on "Attachments: fundraising comparison.sxc."  The 
first screenshot (problem.sxw) just shows SquirrelMail.

Step-by-step:
1. Login to SquirrelMail
2. Open the message
3. Click "Attachments: fundraising comparison.sxc."
4. Get result in second screenshot (see problem.sxw).

I repeated these steps on a second computer in our office with same 
results.  The computer is also IE 6, OOO 1.1, and Win ME.

Thanks.
Comment 7 diane 2003-11-13 13:18:01 UTC
Hi, 

Thank you for your time. I am not able to see the screenshots in the
attached file. I see two places where images should be in the file,
but there are no images, only tags. Perhaps on your system the file
has the 'Linked' box is checked under Insert | Graphics? If this is
checked, the graphics are only linked to the document, instead of part
of it. This Linked feature should not be selected, unless you send the
image files along with the document that links to them. Will you
please try to send the screenshots again? They are a critical piece of
your failure steps and without them the failure you are seeing is not
clearly defined.

Can the attachments that are sent in SquirrelMail be opened with OOo
if they are first saved to the hard drive, then opened directly with
OOo, outside of the SquirrelMail application?

Changed summary field from "Internet Explorer extension" to "OOo
attachments in SquirrelMail do not open properly". Does this better
pinpoint the issue discussed in this report?

Kind Regards,
Diane 
Comment 8 aziem 2003-11-21 00:46:52 UTC
>Thank you for your time. I am not able to see the screenshots in the
> attached file. I see two places where images should be in the file,

Sorry.  I even tested the sxw at home with an older version of OOO on 
a different OS--and was able to see it.  I will try again.

> Can the attachments that are sent in SquirrelMail be opened with OOo
> if they are first saved to the hard drive, then opened directly with
> OOo, outside of the SquirrelMail application?

Yes.  In fact, I can click SM's Download link and then choose Open.  
This also opens the document correctly.

The difference b/w Download and clicking the file name link is that 
the latter is supposed to open the document inside the browser (IE6).

> Changed summary field from "Internet Explorer extension" to "OOo
> attachments in SquirrelMail do not open properly". Does this better
> pinpoint the issue discussed in this report?

Sounds good.



Comment 9 aziem 2003-11-21 00:52:05 UTC
Created attachment 11433 [details]
screenshot
Comment 10 diane 2003-11-22 13:41:49 UTC
Issue 21365 may be similar? Changed component from support to framework.
Comment 11 aziem 2003-12-01 21:03:27 UTC
Created attachment 11681 [details]
"You must be logged into SM"
Comment 12 diane 2003-12-01 21:27:09 UTC
changed qa contact from issues@support.openoffice.org to
issues@framework.openoffice.org, because the support project is or has
been moved.
Comment 13 stx123 2004-05-18 15:32:31 UTC
changing component to ui
Comment 14 Martin Hollmichel 2005-07-01 15:31:53 UTC
reassign to default owner.
Comment 15 thorsten.martens 2005-08-10 12:51:44 UTC
TM->ATR: Mail-problem or plugin-problem ? Please have a look, thanks !
Comment 16 atr 2005-08-10 13:14:39 UTC
ATR->TRA: Hi Tino, please have a look at this issue. I think this is a
enhancement then a defect, because OOo doesn't support SquirelMail.
Comment 17 tino.rachui 2005-08-22 09:58:48 UTC
Is OOo the only application which doesn't work with SquirrelMail? What about
Word, Wordpad, etc.? In order to isolate the problem I need more information
about what exactly doesn't work. Please consider that I do not know SquirrelMail
at all so please write detailed.  
Are you able to open OOo attachments using Mozilla or Thunderbird?
SquirrelMail is not officially supported by OOo this issue seems to be rather an
ehancement than a bug based on what I understood from the bug description and
rather P4 than P3. 
Comment 18 aziem 2005-08-22 14:07:33 UTC
The problem is specific to OOo and Internet Explorer.  OOo can be embedded in
MSIE.  SquirrelMail is a web-based e-mail system.  When opening an attachment
from SquirrelMail, OOo tries to open inside MSIE and OOo tries to fetch the
attachment via HTTP from SquirrelMail.  SquirrelMail refuses because OOo does
not present the session cookie.   I suppose the specific issue is that OOo
should present session cookies inherited from MSIE.  You can see all this
happening in the attachment <sm_oo_login.doc>.

There are no problems with Firefox and Thunderbird because they download the
attachment, store it locally, and then call OOo.  Microsoft Word and Wordpad
work OK with SquirrelMail.  
Comment 19 tino.rachui 2005-08-23 08:13:38 UTC
TRA->MAV: Seems as it has to do with the IE plugin. Could you have a look on it
maybe?
Comment 20 aziem 2005-10-24 19:04:06 UTC
Summary: "OOo attachments in SquirrelMail do not open properly" --> "Session
cookies not sent when embedded in MSIE"

BTW, I can confirm the problem exists in OOo 2.0.0 final with Windows 2000 and
latest MSIE 6.
Comment 21 aziem 2006-08-30 22:50:50 UTC
*** Issue 69102 has been marked as a duplicate of this issue. ***
Comment 22 Olaf Felka 2006-08-31 08:48:26 UTC
Adjusting target according to issue 69102.
Comment 23 Mathias_Bauer 2007-12-04 16:17:30 UTC
according to release status meeting -> target 3.x
Comment 24 Marcus 2017-05-20 10:55:35 UTC
Reset assigne to the default "issues@openoffice.apache.org".