Issue 22154 - long filename being converted to 8.3 filename
Summary: long filename being converted to 8.3 filename
Status: CLOSED OBSOLETE
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1
Hardware: PC Windows 2000
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-11-05 15:25 UTC by Unknown
Modified: 2020-01-19 08:57 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-11-05 15:25:59 UTC
Not sure whether to file this under UI or CODE.

Steps to reproduce:

1)  Open Spreadsheet application or create a new spreadsheet in an existing instance.
2)  Drag/Drop a supported file (I tried an Excel 97 .xls and an ascii .csv) with a long filename onto the spreadsheet.

Note titlebar text is mangled to an 8.3 filename.  Also, if you attempt to "File/Save As" the mangled 8.3 filename will be the default name in the dialog box.
Comment 1 frank 2003-11-05 15:46:23 UTC
Hi Niklas,

one for you ?

You need an spreadsheet open and at least dropping a filename with
more than 8 Characters and an underscore results in the described
behaviour.

Frank
Comment 2 frank 2004-05-05 10:45:42 UTC
Due to time problems this is re-targeted to OOo2.0
Comment 3 hgerstung 2005-01-03 16:14:59 UTC
This also can be found in the Writer when drag'n'dropping a SXW file from the
Explorer into the active document. This creates a linked section, which is fine
:-), but uses the 8.3 filename for it in the "Edit links" manager. 

Steps to reproduce:
Open new text document in Open Office Writer and drag a SXW-File with a long
filename (e.g."My starting section.sxw") from a Windows Explorer window into it.
Now the "Insert Section" window opens and already shows the filename in 8.3
format (e.g. "MYSTAR~1.SXW"). Select the INSERT Button and open the Edit Links
section (Edit/Links...), there the filename is also displayed in 8.3 format. 

This can be observed in versions 1.1.x and also in 1.9.65 (downloaded today). 

Comment 4 nathanson 2005-02-03 05:02:00 UTC
I couldn't see the original bug, but I could definitely see hgerstung's version
of the bug on OOo1.1.3/WinXP. I couldn't see the bug on Linux (KDE) but that's
hardly suprising :)
Comment 5 hgerstung 2005-02-03 19:02:10 UTC
Is this still scheduled for 2.0? I did not see a fix in one of the recent beta
versions..
Comment 6 mathiasm 2010-07-02 21:56:06 UTC
Fixed in OOo 3.2 at least
Comment 7 Marcus 2017-05-20 11:13:42 UTC
Reset assigne to the default "issues@openoffice.apache.org".
Comment 8 oooforum (fr) 2020-01-17 15:21:38 UTC
Set as obsolete