Issue 22353 - OOo Formulas Do Not Display Correctly in MS Word (Windows XP)
Summary: OOo Formulas Do Not Display Correctly in MS Word (Windows XP)
Status: CONFIRMED
Alias: None
Product: Math
Classification: Application
Component: code (show other issues)
Version: OOo 1.1
Hardware: PC Linux, all
: P4 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-11-11 16:41 UTC by Unknown
Modified: 2013-08-07 14:54 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Screenshot of original in OOo (6.00 KB, image/png)
2003-11-11 17:52 UTC, guido.pinkernell
no flags Details
Screenshot of missing fraction bar in Word Viewer (3.32 KB, image/png)
2003-11-11 17:52 UTC, guido.pinkernell
no flags Details
Fraction bar shows in Viewer when enlarged to 200 % (4.13 KB, image/png)
2003-11-11 17:53 UTC, guido.pinkernell
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-11-11 16:41:14 UTC
Using Red Hat 9.0 Linux, after creating formulas using the formula editor and
saving the document to the latest version of an MS Word .doc file, when opening
the .doc file under Windows XP, none of the Greek letters and none of the math
symbols appear in the formula displays. The formulas appear to be pictures, and
are not editable in MS Word. Opening the same .doc file back in OOo, the
formulas can be edited.
Comment 1 guido.pinkernell 2003-11-11 17:51:20 UTC
I can confirm this with OOo 1.1.0(en) on Win98. Will attach
screenshots with missing fraction bars in MS Word Viewer.

See also Issue 9896 (closed as fixed) and Issue 15460, which both seem
related.
Comment 2 guido.pinkernell 2003-11-11 17:52:03 UTC
Created attachment 11174 [details]
Screenshot of original in OOo
Comment 3 guido.pinkernell 2003-11-11 17:52:56 UTC
Created attachment 11175 [details]
Screenshot of missing fraction bar in Word Viewer
Comment 4 guido.pinkernell 2003-11-11 17:53:42 UTC
Created attachment 11176 [details]
Fraction bar shows in Viewer when enlarged to 200 %
Comment 5 Unknown 2003-11-11 18:49:02 UTC
Increasing the Zoom in MS Word will show the fraction bar. (I tried
this and it does work.) More importantly, the Greek letters and math
symbols (+, -, and so forth) don't show up.
Comment 6 thomas.lange 2003-11-12 11:23:44 UTC
There is a set of options in the dialog "Tools / Options - Load/Save -
Microsoft Office" please have the two boxes for load and save next to
the "MathType" entry checked.

Without that neither MS MathType formulas get imported to OOo or on
export only an image gets exported for the formulas since MS does not
know about the OOo format.

Please check again after activating this options and state which of
the problems remain?

BTW: I see no reason why the letters should not show up as long as
those boxes are not checked because as mentioned an image should be
exported to the doc format...
Comment 7 guido.pinkernell 2003-11-17 15:38:05 UTC
I have checked again (win98), with option exporting the OOo formula to
MathType enabled and not enabled. It makes no difference. In both
cases the fraction bar doesn't show in Word viewer, this time - with
formula {%DELTA f(x)} over {%DELTA x} - not even with Word viewer zoom
factor set to 200%. I need to enlarge to about 270% to be able to see
the fraction bar.

The Delta does show, however, with any zoom factor.

This Issue obviously needs to be separated into the fraction bar
display problem (which seems to be a dup of Issue 9896) and the greek
font display option. I can't find a duplicate of the latter.

I suggest to reopen 9896 and modify this Issue so that it focusses on
the font display.
Comment 8 thomas.lange 2003-11-18 09:22:17 UTC
TL->MRU: Please have a look at this. 
Especially at any differences/faults that may exist additionally in
Win98 only.
Comment 9 stefan.baltzer 2003-11-28 16:02:23 UTC
SBA: Target set to OOo 2.0.
Comment 10 michael.ruess 2004-02-05 11:22:12 UTC
MRU->SJ: Not a problem of the MathType or Word export. The fraction bar is
available when exported (when activating the object in Word, it is visible). It
looks, that it is not correctly exported to the Object's Metafile preview of MS
Format.
Comment 11 michael.ruess 2004-04-28 15:28:48 UTC
re-targeted to "OO later".
Comment 12 sven.jacobi 2004-05-27 15:46:18 UTC
SJ->THB: seems to be a problem with our metafile import, please take a look.
Comment 13 thb 2008-06-27 15:35:45 UTC
@sj: please take this one back.