Issue 22398 - undo does not undo edit to paragraph format
Summary: undo does not undo edit to paragraph format
Status: CLOSED DUPLICATE of issue 21502
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-11-12 23:00 UTC by gpolitis
Modified: 2004-02-02 00:07 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description gpolitis 2003-11-12 23:00:55 UTC
If the "Auto Update" flag is set in the paragraph style, changes to paragraph   
style via Format->Paragraph... appear in the undo/redo list, but the undo   
operation does not reverse the change (forked from issue 22368).  
  
Example of how to duplicate problem:  
  
1. Create new text document.  
2. Format->Styles->Catalog, click New...  
3. Type Name=fred, Next Style=fred, tick AutoUpdate, hit OK.  
4. Double click on new style, "fred". Current paragraph now has style "fred".  
5. Type: Hello, world!  
6. Format->Paragraph->Indents & Spacing  
7. Enter 1cm for From left and hit OK. Text is now indented.  
 
At this point, undo lists three additional entries. Attempting to undo does 
not appear to achieve anything. If "AutoUpdate" was not ticked, undo at this 
point lists one entry, and undo/redo work as expected.
Comment 1 guido.pinkernell 2004-02-01 17:37:21 UTC
Confirmed with OOo 1.1.0 on Win98
Comment 2 lohmaier 2004-02-01 23:57:28 UTC
duplicate.

*** This issue has been marked as a duplicate of 21502 ***
Comment 3 lohmaier 2004-02-02 00:07:45 UTC
see also http://specs.openoffice.org/writer/index.html -> "General Undo
Enhancements in Writer"
(http://specs.openoffice.org/writer/undo/Undo_GeneralWriter.sxw)
closing duplicate.