Issue 22413 - Problems with cut & paste mixed text & images from HTML sources
Summary: Problems with cut & paste mixed text & images from HTML sources
Status: CLOSED DUPLICATE of issue 37652
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 RC5
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-11-13 09:45 UTC by jpardo
Modified: 2007-02-03 01:42 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Zip file containing some swx and PDF sample cases (289.76 KB, application/zip)
2003-11-14 10:28 UTC, jpardo
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jpardo 2003-11-13 09:45:42 UTC
When pasting information taken from web pages into text documents.
Problems arise with images included into the original HTML page. The Word
processor renders the text quickly and without problems, but apparently blocks
itself with the images (more than 10 seconds with each one), and many times it
finally renders only the image reference, but not the graphics content.

You can easily reproduce the problems if you try to cut information from that
URL (http://www-106.ibm.com/developerworks/opensource/library/os-ecc/) and then
paste it into a newly created text document.
MS-Word renders the resulting document without a glitch, so there's no problem
with the original information in HTML.
Comment 1 utomo99 2003-11-14 09:20:14 UTC
which browser you are using, and what is your VGA card ? 
which part of the text you are copying 
start
until 
Comment 2 jpardo 2003-11-14 10:28:21 UTC
Created attachment 11257 [details]
Zip file containing some swx and PDF sample cases
Comment 3 jpardo 2003-11-14 10:30:14 UTC
OpenOffice issue# 22413
-----------------------

a) My video card is a Matrox Millenium II AGP with 8MB frame buffer.

b) The cut & pasted content is always taken from the following URL:

    http://www-106.ibm.com/developerworks/opensource/library/os-ecc/

To avoid including frames we cut only from the central text + graphics
frame.

    - Starting from the line: "How to use the...."

    - and ending in the line: "Linux columnist for the Polish..."


I include samples taken from three different cases:


Case 1:
    Mozilla Firebird rev. 0.7 for Win32.
    Paste over a newly created text document with default paste settings.
    (Special paste only offers raw text, html and html without comments).

Case 2:
    Internet Explorer rev. 6.0.2800.1106
    Paste over a newly created text document with default paste settings.
    (Special paste offers raw text,html,html without commnets and RTF).
    In this case not only the images are incorrectly rendered, but also
    significant parts of the text are lost.

Case 3:
    Internet Explorer rev. 6.0.2800.1106
    Special paste over a newly created text document as RTF.
    This option provides similar results as to the case 1.


Resulting swx and directly exported PDF samples are included for all
three cases.
(In a ZIP compressed attachment).
Comment 4 jpardo 2003-11-21 17:16:13 UTC
As far as I understand, this seems to be the behaviour of the cut &
paste process from a web browser:

It gets all the html formatted text directly, but it only gets the
URLs which point to the images.
This means that it must be the OpenOffice application which gets the
image data straight from the specific URL.

In my case this presents an inconvenient, because my company has a
proxy server which requires an initial login by means of a userid and
a password.
Apparently this requierement is not detected nor satisfied by the
OpenOffice applications, which block until some timeout makes them
pass over the image rendering, leaving it blank.

When I do the same process with MS-Word form the first time, my
desktop shows a login window, asking for my userid and password. Once
I fill in the corresponding data the images are rendered correctly.

That's why i guess where the problem comes from (I have the proper
proxy configuration set up in my OpenOffice options dialog).

Comment 5 jack.warchold 2004-02-16 12:03:48 UTC
reassigend to jw
Comment 6 jack.warchold 2004-02-17 14:46:16 UTC
yes you are right OOo is not able to logon to a proxy with password protection.

i will change the issue type to enhancement and reassign this issue to the owner of 
enhancement issues
Comment 7 lohmaier 2007-02-03 01:42:32 UTC
duplicate.

*** This issue has been marked as a duplicate of 37652 ***
Comment 8 lohmaier 2007-02-03 01:42:50 UTC
closing duplicate.