Issue 22519 - Handling DUPLICATE issues
Summary: Handling DUPLICATE issues
Status: RESOLVED FIXED
Alias: None
Product: Infrastructure
Classification: Infrastructure
Component: Bugzilla (show other issues)
Version: current
Hardware: All All
: P3 Trivial with 12 votes (vote)
Target Milestone: CEE 5.2
Assignee: Unknown
QA Contact: issues@www
URL:
Keywords:
: 22825 56564 56565 57393 65006 84534 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-11-16 23:04 UTC by oblomov
Modified: 2009-01-28 10:19 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description oblomov 2003-11-16 23:04:34 UTC
When CLOSING issues as DUPLICATE, there are some things that should get handled 
automatically: currently, all comments to any of the duplicats appears on all 
the issues.

I believe that votes should be cloned to: if I vote for IZ#<something> and this 
is closed as DUPLICATE of IZ#<another>, my votes should count in favour of 
IZ#<another> (since the two issues are supposed to be the same, it makes sense 
to merge the votes).

Also, if IZ#<something> is CLOSED as DUPLICATE, it won't appear on the "My 
issues" list, even if IZ#<another> is not closed itself. Maybe marking as 
duplicate shouldn't CLOSE the issue?
Comment 1 chadley78 2003-11-18 05:09:33 UTC
*** This issue has been confirmed by popular vote. ***
Comment 2 maison.godard 2003-11-25 08:06:29 UTC
*** Issue 22825 has been marked as a duplicate of this issue. ***
Comment 3 maison.godard 2003-11-25 08:08:26 UTC
adding myself to CC
Comment 4 rblackeagle 2003-11-25 10:30:14 UTC
When you marked 22825 as a duplicate, did you transfer the votes?  I
personally find it reprehensibly irresponsible to do anything else.
Comment 5 maison.godard 2003-11-25 11:10:18 UTC
Hi Robert,

sorry ! I don't understand your question

The 22825 is an issue i just created and were there were no vote
But in fact you ask me if i transfered when i duplicate !! this is 
exactly what this issue deals with
Is there any hint to report the Votes from one issue to an other i 
have to know ?

thanks

Laurent
Comment 6 stx123 2004-04-27 17:26:40 UTC
I don't understand all parts of the initial description. I don't think that
duplicating the comments is useful. Furthermore an issue is not closed if marked
as duplicate. It's RESOLVED with the resolution "DUPLICATE" and should be
verified before final closure.

But I think the following data should be "cloned"
- votes (up to the limit for each user)
- duplicates

Reassigning to support.
Comment 7 Unknown 2004-04-29 00:22:46 UTC
Hi Stefan,

As I understand this issue, you would like the votes to auto populate to
duplicate issue in IZ.
I spoke to engineering about this enhancement request. Right now Collab is
focusing resources on Project Tracker & not on complex enhancements to IZ beyond
serious maintence.

Closing this as wont fix for now.
Eric
Comment 8 stx123 2004-04-29 11:17:21 UTC
Hi Eric,
Yes, your understanding of the issue is correct.
I'm not bound to IssueTracker (aka IssueZilla) for this issue.
It's fine with me, if you take it into consideration for PT.
Thanks, Stefan
Comment 9 Unknown 2004-04-29 19:54:38 UTC
I created pcn 	28394 to monitor this request for enhancement,
Eric
Comment 10 Unknown 2004-08-05 19:40:24 UTC
Moving this issue to RESOLVED->LATER statuts.
Comment 11 Unknown 2004-08-05 21:21:12 UTC
Reopening this issue. Mistakenly marked this as RESOLVED->LATER. Will follow 
up with engineering regarding this.
Comment 12 Unknown 2004-10-26 02:33:45 UTC
CollabNet is not planning to do this level of enhancement in IZ.  However, 
there is strong possibility to include this when we implement voting in 
Project Tracker. Marking this as RESOLVED->REMIND
Comment 13 yunkong 2005-10-25 09:10:57 UTC
*** Issue 56565 has been marked as a duplicate of this issue. ***
Comment 14 yunkong 2005-10-25 09:12:36 UTC
*** Issue 56564 has been marked as a duplicate of this issue. ***
Comment 15 yunkong 2005-10-25 09:12:47 UTC
*** Issue 56564 has been marked as a duplicate of this issue. ***
Comment 16 lohmaier 2005-11-15 01:21:08 UTC
*** Issue 57393 has been marked as a duplicate of this issue. ***
Comment 17 Rainer Bielefeld 2006-12-19 17:08:19 UTC
*** Issue 65006 has been marked as a duplicate of this issue. ***
Comment 18 Rainer Bielefeld 2006-12-21 05:56:35 UTC
*** Issue 65006 has been marked as a duplicate of this issue. ***
Comment 19 Unknown 2007-03-11 03:26:29 UTC
Reopening to change/update the current status of the issue .
Comment 20 Unknown 2007-12-28 07:42:13 UTC
Hi,

We will try to consider this request in Project Tracker if OpenOffice decides to
move to PT. Marking as RESOLVED -> LATER.


Thanks,
Jeeva
Support Operations
Comment 21 chadley78 2007-12-28 15:14:43 UTC
Considering this issue was opened THREE YEARS AGO - Marking it "Later" now just
shows how this shit will never get fixed.
Comment 22 raindrops 2008-05-18 08:29:46 UTC
I do not understand why resolution is set to "resolved". 

Please refer to http://qa.openoffice.org/scdocs/issue_lifecycle.html.

The "RESOLVED" status is to be used when the target system (here, issuezilla) is
modified, and awaiting verification. 

In other words, this resolution means that all possible actions are already
taken; and nothing needs to be done further if everything goes well.

But is that so? All that Jeeva offers is to "consider it" **IF** OOo migrates
from IssueZilla to Project Tracker. That's two remote possibilities rolled into
one! 

OK let us pretend that those two actions WILL happen in future. Even then, does
this issue deserve a "Resolved" status TODAY? I think Jeeva just handed a death
sentence to it. 

Sadly, Sun/OOo staff sweeps maximum possible issues under carpet like this; and
I don't see a voice of sanity who calls out a halt to this madness.

The correct process is to keep the issue OPEN and forward it to the policymaker
who decides whether to migrate to Project Tracker.
Comment 23 ace_dent 2008-05-18 22:16:31 UTC
*** Issue 65006 has been marked as a duplicate of this issue. ***
Comment 24 Martin Hollmichel 2008-05-30 06:43:09 UTC
@raindrops:

The status resolved/later is not a valid status for issues for the
OpenOffice.org product. This status is only used for issues regarding the
collab.net infrastructure if issues has been solved for a CEE release which has
not been applied yet to the OpenOffice.org website infrastructure.
Comment 25 raindrops 2008-06-02 15:29:30 UTC
That's exactly my point: Is a new feature added to Issuezilla, which solves this
problem? At this point of time, it may be under testing.

If that has NOT happened, then it is NOT resolved.
Comment 26 Unknown 2009-01-19 11:07:21 UTC
CollabNet Support is currently reviewing the issues under Resolved-Later. If the
issues are fixed currently in any of the present CEE releases, then it will be
marked as Resolved-Fixed.

There might be a few issues which might not be in our future roadmaps which
might be closed as Wontfix unless it does not lie under any custom request.
Comment 27 Unknown 2009-01-22 10:43:48 UTC
*** Issue 84534 has been marked as a duplicate of this issue. ***
Comment 28 Unknown 2009-01-28 10:19:48 UTC
When changing an issues component, all existing votes were automatically
removed. In CEE 5.2 P1,now there is an option so that the votes can be preserved 

1-Precondition: Set 'remove votes' - 'ON' under 'Issue organization' section' of
'Edit advanced configuration options
(edit setting)' page under 'configuration
options' page and save settings.

Observations: All the votes are removed when the user changed the component to
something else. And the respective votes
received email notification about the removal of votes on the issue.


2-Precondition: Set 'remove votes' - 'OFF' and save the setting under 'Edit
advanced configuration options (edit
setting)' page under 'configuration
options' link.

Observed: All the votes count are remaining the same even after changing the
component to something else.

Regards,
Ramya
Support Operations