Issue 23156 - Dashes following a quote are not converted to em-dash
Summary: Dashes following a quote are not converted to em-dash
Status: CLOSED DUPLICATE of issue 5018
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1
Hardware: PC Linux, all
: P3 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: Oliver Specht
QA Contact: issues@sw
URL:
Keywords: oooqa
: 89130 (view as issue list)
Depends on:
Blocks:
 
Reported: 2003-12-03 15:47 UTC by rblackeagle
Modified: 2013-08-07 14:38 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description rblackeagle 2003-12-03 15:47:29 UTC
If there is a quote or other punctuation preceding or following a dash or
double-dash, the dash is not converted to an em-dash.  To get an em-dash, I have
to make sure there is nothing on either side of the dash except an alphabetic
character.  The autoreplace function should work consistently and reliably.  It
doesn't.
Comment 1 srobertson 2003-12-09 22:44:16 UTC
Verified on OpenOffice.org 1.1.0, built from sources on Gentoo Linux. 
 
I don't know whether it's intentional or not, but it is reproducible. 
Comment 2 jack.warchold 2003-12-11 17:33:24 UTC
reassigend to jw

i will take a look on this
Comment 3 jack.warchold 2003-12-15 15:40:19 UTC
reassigned khong

can you please take a look on this issue. us@openoffice.org told me that this 
might be somthing for you. even if you just can tell us why this is not fixable.

Comment 4 jack.warchold 2003-12-15 15:41:23 UTC
.
Comment 5 karl.hong 2003-12-15 23:04:40 UTC
Sorry, what is em-dash? what do you expect autoreplace to convert dash to
em-dash, could you give me more detail step to reproduce the problem.
Comment 6 rblackeagle 2003-12-16 05:27:04 UTC
An en-dash is a dash as long as the letter "n" in proportional fonts.  An
em-dash is as long as an "m" in the same font.  En-dashes are used for hyphens.
 Em-dashes are used as punctuation marks and are required by almost all publishers.
Comment 7 rblackeagle 2003-12-16 05:58:14 UTC
Sorry, I failed to respond to your entire questions.  An em-dash is produced
after the writer types <space> - <space> or <space> -- <space> and replaces the
dashes (en-dashes) with em-dashes.  Every word processor I've seen for the past
20 years does this (I'm 62).  However, OOo does NOT do it if there is
<punctuation mark> <space> <- or --> <space> or <space> <- or --> <space>
<punctuation mark>.  That failure occurs with quotes and commas (the most common
places).

For example, typing <Jack," -- he said> leaves double en-dashes.  I have to go
in and type <Jack,"j -- he said> and then delete the extra j to get it to work.
 In other words, the replacement is not looking at <space> <- or --> <space> to
determine an em-dash (as it should) but at <character> <space> <- or --> <space>
<character> and if <character> is a punctuation mark, fails to replace the dashes.

It's a bug found in no other word processor.  I would hope it's an easy fix.
Comment 8 karl.hong 2003-12-18 18:07:48 UTC
Karl->OS: It seems an autocorrection problem, if you found that is caused by
breakiterator, please give me your comment and send back to me.
Comment 9 Oliver Specht 2003-12-19 11:43:10 UTC
.
Comment 10 rblackeagle 2004-03-05 17:52:22 UTC
Same problem persists in 1.1.1rc.  No change in behavior.
Comment 11 rblackeagle 2004-04-24 20:48:47 UTC
Problem persists in 1.1.2rc.
Comment 12 julianna 2006-04-20 12:11:06 UTC
Can this be merged with issue 5018?
Comment 13 stefan.baltzer 2007-07-18 17:05:56 UTC
SBA: In my opinion, this one is a duplicate of enhancement issue 5018.

*** This issue has been marked as a duplicate of 5018 ***
Comment 14 lohmaier 2008-07-15 18:29:54 UTC
*** Issue 89130 has been marked as a duplicate of this issue. ***
Comment 15 Mechtilde 2008-11-05 20:25:45 UTC
close the duplicate