Issue 23300 - API: sw.SwXNumberingRules::XIndexReplace
Summary: API: sw.SwXNumberingRules::XIndexReplace
Status: CLOSED FIXED
Alias: None
Product: App Dev
Classification: Unclassified
Component: api (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: All All
: P4 Trivial
Target Milestone: ---
Assignee: stephan.wunderlich
QA Contact: issues@api
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-08 11:49 UTC by stephan.wunderlich
Modified: 2013-02-24 21:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description stephan.wunderlich 2003-12-08 11:49:26 UTC
Objectrelation for this interface-test is missing
Comment 1 stephan.wunderlich 2004-01-13 09:40:00 UTC
SW: added to cws_qadev16
Comment 2 stephan.wunderlich 2004-01-14 14:53:55 UTC
SW: removed from cws_qadev16
Comment 3 stephan.wunderlich 2004-01-14 14:57:55 UTC
SW->TL: the office crashes when the method replaceByIndex is used with wrong
argument. To reproduce, just execute the following macro.

StyleFamilies = thisComponent.getStyleFamilies()
StyleFamily = StyleFamilies.getByName("NumberingStyles")
NStyle = StyleFamily.getByIndex(0)
NRules = NStyle.NumberingRules
aRule = NRules.getByIndex(0)
NRules.replaceByIndex(999, aRule)
Comment 4 thomas.lange 2004-01-15 14:50:22 UTC
.
Comment 5 stephan.wunderlich 2004-05-03 12:20:19 UTC
SW: changed prio
Comment 6 Martin Hollmichel 2004-05-28 15:22:17 UTC
according to the announcement on releases
(http://www.openoffice.org/servlets/ReadMsg?list=releases&msgNo=7503) this issue
will be re-targeted to OOo Later.
Comment 7 stephan.wunderlich 2004-06-01 09:15:06 UTC
SW->TL: as discussed back to OOo2.0 since they are fixed in a current CWS
Comment 8 thomas.lange 2004-06-01 09:21:44 UTC
Fixed in CWS tleamisc.
Files changed:
- unosett.cxx 1.35.172.2
- unosett.hxx 1.6.500.1
Comment 9 thomas.lange 2004-08-06 12:05:20 UTC
.
Comment 10 thomas.lange 2004-08-06 12:05:42 UTC
OK in CWS tleamisc.
Comment 11 stephan.wunderlich 2004-08-09 11:09:52 UTC
SW->TL: replaceByIndex still throws an IllegalArgumentException for valid indexes
Comment 12 thomas.lange 2004-08-09 14:10:51 UTC
TL->SW: Works for me. Please check again.
Comment 13 stephan.wunderlich 2004-08-10 14:43:05 UTC
fixed in cws_tleamisc
Comment 14 stephan.wunderlich 2004-08-10 14:43:27 UTC
works as expected in cws_tleamisc => verified
Comment 15 stephan.wunderlich 2004-09-10 09:36:43 UTC
ok in src680_m52 => closed