Issue 23487 - Please add document-code-editing feature
Summary: Please add document-code-editing feature
Status: CLOSED DUPLICATE of issue 3395
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-12-11 23:30 UTC by pr0net
Modified: 2012-02-19 22:30 UTC (History)
1 user (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
the undeletable non-bug in question (.sxw) (5.31 KB, application/octet-stream)
2003-12-11 23:31 UTC, pr0net
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description pr0net 2003-12-11 23:30:32 UTC
It would be really nice, if a feature like Word Perfect's "show codes"/"show
source" was implemented. That is, I would like to be able to edit the specific
tags in the document, like font-change, table definitions and so on. Like when
editing html-code.

At least once in each project, you come across fonts, borders or something else
acting "strange".

For example: start writing a document. type a few words. Press enter. Add three
minusses. Press enter. The minusses are converted into a line. Write a couple of
more words. Now delete the line. You can't!

So, this should be a bug-report on the "undeletable line"-bug. But it isn't.
This just goes to show, that stuff like this occurs. It happens in Word, it
happens in Word Perfect, and it happens in OpenOffice. Being able to view the
code, enables me to fix it, without filing a bug-report.

It would imo be a very strong feature for OpenOffice-writer to include this.
Comment 1 pr0net 2003-12-11 23:31:40 UTC
Created attachment 11899 [details]
the undeletable non-bug in question (.sxw)
Comment 2 pr0net 2003-12-11 23:56:04 UTC
I just realised that .sxw were actually zipped files.

A quick look around tells me, that what I want, is to be able to edit the
"contents.xml" directly. Which looks sort of impossible.

A more document-near way of editing would still be a great idea though!! These
kind of bugs are much easier to fix, if when such features exist.
Comment 3 lohmaier 2003-12-12 16:05:53 UTC
The line is a paragraph border. Just apply the "Standard" or any other paragraph
stylte to the line and you're done. -> see also issue 21299
the reveal codes-thingy is filed as issue 3395

->duplicate

*** This issue has been marked as a duplicate of 3395 ***
Comment 4 lohmaier 2003-12-12 16:07:12 UTC
closing duplicate
Comment 5 pr0net 2003-12-12 16:39:09 UTC
Like I stated, this was not the issue. I was suggesting a feature.

Now I know why this exact problem happened. But it was not obvious why at the
moment - still isn't, really. I still suggest adding an easy way to edit
document-code directly. Your formula-editor is an excellent example of a system
that works.
Comment 6 lohmaier 2003-12-12 17:21:02 UTC
Quote from my comment:
######
the reveal codes-thingy is filed as issue 3395

->duplicate

*** This issue has been marked as a duplicate of 3395 ***
######

Please have a look at issue 3395

Back to the example: When entering the three minus and enter an autoFormat is
performed. When this happens for the first time(s), a small window showing a
lightbulb appears in the lower right corner of the document window. Klick it and
you will be directed to the OnlineHelp where you can read what happend, why this
happend and how you can turn this off.
Use Tools|AutoCorrect/AutoFormat -> options and uncheck "apply border".
Comment 7 pr0net 2003-12-12 17:27:37 UTC
I appologize. Thanks for your time. :)
Comment 8 T. J. Frazier 2012-02-19 22:30:04 UTC

*** This issue has been marked as a duplicate of issue 3395 ***