Issue 23732 - Embedding font info in exports
Summary: Embedding font info in exports
Status: CLOSED DUPLICATE of issue 20370
Alias: None
Product: Impress
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 RC5
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@graphics
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-12-19 15:50 UTC by marcstuessel
Modified: 2005-08-06 18:19 UTC (History)
2 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description marcstuessel 2003-12-19 15:50:24 UTC
Situation:
1. Writing a presentation that uses either PostScript or TrueType fonts that 
are not standard PC fonts (e.g. Linotype Frutiger New)
2. Exporting this presentation as Microsoft PPT

Problem:
When the exported PPT is opened using PowerPoint on a different PC where that 
font is not installed, then the font is substituted by PoerPoint for some other 
font. This is bad, as the font size also changes and the entire presentation 
looks horrible.

Proposed Solutions:
1. When a presentation is being exported, the font info somehow needs to travel 
with the presentation. This could be achieved by either generating a separate 
file that includes the font info (if the PowerPoint format does not allow to 
embed font info) or (preferably) by taking the PDF approach of embedding the 
font info into the generated file. Also, as in Microsoft Word, this 
functionality should be optional, i.e. the user selects the option explicitly.

2. Similar to PowerPoint, there could be some kind of auto-run environment 
which generates an OpenOffice presentation that runs on any computer in kind of 
a sandbox if and when OpenOffice is not installed on that computer.
Comment 1 wolframgarten 2003-12-22 13:36:14 UTC
Reassigned to Christian.
Comment 2 christian.guenther 2004-01-06 08:06:37 UTC
I think this are 2 feature requests and not bugs.
Please have a look.
Comment 3 marcstuessel 2004-01-06 13:45:50 UTC
Yes, these appear to be two feature requests, my fault.
May I just point out how important this is:
At the moment I work as an independent contractor for a large car manufacturer. 
There is no way that I bring my laptop to their premises (security/secrecy). In 
addition,there is also no way that I install OpenOffice on their machines (not 
allowed and no local admin provileges). 
On the other hand, I prepare things outside any customers premises. My 
corporate identity builds on graphic elements and fonts that are not PC-
standard.
So what do I do? 
Thete just has to be really good interoperability between leading (in terms of 
market percentage) and competing product; otherwise there is no way that I can 
use OpenOffice in an enterprise environment where Powerpoint rules.
And nobody else either, for that matter.
Comment 4 sergey_feo 2005-02-22 17:18:19 UTC
Hm... As I now (correct me if its wrong), OpenOffice can't include fonts in its 
own documents, not only in non-native formats.... I reported about this in issue 
 42687. So, if you have all admin rights to install OpenOffice on target 
machine, you can't see you presentations too :(
Comment 5 lohmaier 2005-08-06 18:18:41 UTC
OOo can embed fonts in PDFs.

OOo probably will never be able to embed fonts in powerpoint files since this
would require a license (pay for) MicroType Express technology from Agfa (this
is what Microsoft uses) - So you have to look for a sponsor...

But it doesn't make sense to have multiple issues for the same thing, so I'm
closing this one.

*** This issue has been marked as a duplicate of 20370 ***
Comment 6 lohmaier 2005-08-06 18:19:23 UTC
closing duplicate.