Issue 23851 - can't set directionality for indivudual data fileds
Summary: can't set directionality for indivudual data fileds
Status: CLOSED DUPLICATE of issue 30361
Alias: None
Product: Internationalization
Classification: Code
Component: BiDi (show other issues)
Version: OOo 1.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: falko.tesch
QA Contact: issues@l10n
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-24 13:34 UTC by sforbes
Modified: 2005-02-16 10:27 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
screen shot (63.20 KB, image/png)
2003-12-24 13:34 UTC, sforbes
no flags Details
the actual mail merged file (5.91 KB, application/octet-stream)
2003-12-24 13:35 UTC, sforbes
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description sforbes 2003-12-24 13:34:14 UTC
can't set directionality for indivudual data fileds. This can lead for example
to incurrect display of phone number in mail merged letter.
setting the paragraph directionality is not sufficiant in many cases, as it
produces incurrect results.

See example screen shot of incurrect phone number display. compare to the
currect display in the datasource display above (the marked contact).

having the ability to set the directionality of the filed will prevent this problem.

Note that in the Hebrew OpenOffice 1.1, the fileds are always RTL, while the
English version has them always as LTR (which will cause problems with other
fileds).
Comment 1 sforbes 2003-12-24 13:34:49 UTC
Created attachment 12106 [details]
screen shot
Comment 2 sforbes 2003-12-24 13:35:52 UTC
Created attachment 12107 [details]
the actual mail merged file
Comment 3 Dieter.Loeschky 2004-02-18 14:17:29 UTC
DL->FT: would you please handle this?
Comment 4 falko.tesch 2005-02-16 09:59:29 UTC
FT: double.

*** This issue has been marked as a duplicate of 30361 ***
Comment 5 falko.tesch 2005-02-16 10:27:50 UTC
Closed