Issue 2394 - Xcl Exp: Cyrillic char set
Summary: Xcl Exp: Cyrillic char set
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: 641
Hardware: PC Windows 98
: P3 Trivial (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords:
: 2531 3257 8129 9873 10403 (view as issue list)
Depends on:
Blocks:
 
Reported: 2001-12-03 05:28 UTC by ezh
Modified: 2013-08-07 15:12 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
the xls file (49.50 KB, text/plain)
2001-12-03 05:29 UTC, ezh
no flags Details
the just resaved in OOo xls file. Also compare the file sizes (1.94 MB, text/plain)
2001-12-03 05:32 UTC, ezh
no flags Details
Proposed patch to fix this (2.61 KB, patch)
2003-02-12 20:38 UTC, john.marmion
no flags Details | Diff
No need to use local variable (2.66 KB, patch)
2003-02-13 20:29 UTC, john.marmion
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description ezh 2001-12-03 05:28:53 UTC
1) Open the file in OOo
   a) the green colored cells are shown in OOo as grey
   b) the yellow colored cells are shown in OOo as red

2) Save this file in OOo and try to open with MS Exel
   a) it does not opens due to: "Name cannot be the same as a build-in name. Old
name: _FilterDatabase"
Comment 1 ezh 2001-12-03 05:29:19 UTC
Created attachment 749 [details]
the xls file
Comment 2 ezh 2001-12-03 05:32:52 UTC
Created attachment 750 [details]
the just resaved in OOo xls file. Also compare the file sizes
Comment 3 oc 2001-12-04 09:38:15 UTC
Four Problems on this file:
1. wrong colours after import => allready fixed in next build
2. Name conflict on build-in names (Excel97 only)
3. Increased filesize during export => allready fixed in next build
4. Wrong fontreplacement after export on Win98/Excel97
Comment 4 oc 2001-12-13 18:02:22 UTC
*** Issue 2531 has been marked as a duplicate of this issue. ***
Comment 5 daniel.rentz 2002-01-29 10:09:19 UTC
2) 2do: Better filter for built-in named ranges
4) Exported wrong charset 
(different for cyrillic fonts) - Excel2000 replaces automatically but not 
Excel97...
Comment 6 frank 2002-02-28 14:41:43 UTC
*** Issue 3257 has been marked as a duplicate of this issue. ***
Comment 7 Unknown 2002-08-06 11:32:36 UTC
Also have the 'name conflict' error with an Excel2000 file BUT don't 
always get the same name coming up even if I re-edit the original 
file in Excel 2000 import in OOo, and open in Excel2000 again 
(print_area vs print_titles).
Comment 8 daniel.rentz 2002-08-09 13:55:29 UTC
Name conflict problem fixed in next started 641 build (OOo1.0.2 or 1.0.3).
Reason (very weird): In an Excel file, auto-filters must be sorted in
alphabetical order of the underlying sheet names. In this case the
auto-filter of the third sheet has to be exported before the second
sheet. Wrong order causes the meaningful error in Excel. The OOo
export filter now sorts the auto-filters internally before exporting them.

@Craig: Same happens with print ranges and print titles. Also fixed.

So there remains the charset problem only...
Comment 9 frank 2002-10-16 07:55:01 UTC
*** Issue 8129 has been marked as a duplicate of this issue. ***
Comment 10 daniel.rentz 2002-12-09 08:40:07 UTC
*** Issue 9873 has been marked as a duplicate of this issue. ***
Comment 11 john.marmion 2003-01-02 17:37:14 UTC
*** Issue 10403 has been marked as a duplicate of this issue. ***
Comment 12 daniel.rentz 2003-01-13 16:05:51 UTC
target->OOo2.0
Comment 13 john.marmion 2003-02-03 16:23:54 UTC
Taking responsibility for this. Can create this using Excel97.
Comment 14 john.marmion 2003-02-03 16:24:25 UTC
marking as started
Comment 15 john.marmion 2003-02-12 20:38:26 UTC
Created attachment 4696 [details]
Proposed patch to fix this
Comment 16 john.marmion 2003-02-13 20:29:02 UTC
Created attachment 4716 [details]
No need to use local variable
Comment 17 john.marmion 2003-02-13 20:34:26 UTC
Checked in latest patch today.
Comment 18 john.marmion 2003-02-19 10:17:52 UTC
re-open to assign to QA
Comment 19 john.marmion 2003-02-19 10:18:28 UTC
assigning to QA
Comment 20 john.marmion 2003-02-19 10:19:09 UTC
restore "fixed" status
Comment 21 frank 2003-04-07 15:04:07 UTC
verified in Calc06 on Solaris and Windows Version
Comment 22 frank 2003-04-16 13:56:23 UTC
found integrated on srx644m10s1 using Solaris, Windows and Linux