Issue 24011 - Text does not flow around certain draw frames
Summary: Text does not flow around certain draw frames
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-31 10:37 UTC by jvromans
Modified: 2004-01-09 11:30 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jvromans 2003-12-31 10:37:55 UTC
Draw frames can be placed on arbitrary positions on the page, no matter where
they are anchored to.

When a draw frame is anchored to the header frame (or footer, I assume), and
placed somewhere over the page frame, the text of the page frame does not flow
around it, no matter what "wrap" settings are selected for the draw frame.

The text will wrap according to the settings when the draw frame is anchored to
the page, or to the text frame, but not when anchored to the header frame. This
seriously limits the use of draw frames. Anchoring the draw frames to the header
frame is currently the only way to make them part of the page style.

There will be no loss of functionality when this behaviour is fixed, since the
current behaviour can be obtained by selecting "wrap through" for the draw frames.
Comment 1 h.ilter 2004-01-06 09:31:43 UTC
dublicate to 24012

*** This issue has been marked as a duplicate of 24012 ***
Comment 2 h.ilter 2004-01-06 09:32:41 UTC
.
Comment 3 jvromans 2004-01-08 21:29:59 UTC
I object to the duplicate marking. Although the two issues concern the same
objects (draw frames) the problems are quite different.

In this case it is an error of some sort since the properties tab allows you to
select the wrap type for the draw frame, and then does not honour the selected
type. This is truly a defect. Either disallow wrap type selection, or
(preferred!) fix the wrap behaviour.
Comment 4 h.ilter 2004-01-09 11:29:45 UTC
The duplicate is the kind of handling with draw frames. 
This means, when the draw frames will be handled like the normal frames, then we
get with the new feature two fixes with one step.
In current it works like it is designed.
Comment 5 h.ilter 2004-01-09 11:30:32 UTC
closed again.