Issue 24124 - WW8: export completely loses hidden text field
Summary: WW8: export completely loses hidden text field
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 680m17
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords:
: 4135 17064 24178 (view as issue list)
Depends on:
Blocks:
 
Reported: 2004-01-06 07:45 UTC by michael.ruess
Modified: 2019-07-22 10:05 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Doc from Issue 947. Open in Writer and save as WW8. (19.00 KB, application/msword)
2004-01-06 07:47 UTC, michael.ruess
no flags Details
Attach as .sxw as this will be imported as a char attribute in the future. (74.77 KB, application/vnd.sun.xml.writer)
2004-01-14 15:17 UTC, caolanm
no flags Details
last attachment was the wrong one, this is the right one (5.96 KB, application/vnd.sun.xml.writer)
2004-01-14 15:18 UTC, caolanm
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description michael.ruess 2004-01-06 07:45:37 UTC
The WW8 export filter completely loses hidden text. Import works fine. As long
as OOo 2.0 offers full support for the RTF filter, this should also work for
Word format filter.
Comment 1 michael.ruess 2004-01-06 07:47:06 UTC
Created attachment 12286 [details]
Doc from Issue 947. Open in Writer and save as WW8.
Comment 2 michael.ruess 2004-01-06 07:48:08 UTC
It is a kind of "key feature. Thus it is targeted to OO 1.1.2.
Comment 3 caolanm 2004-01-14 15:17:56 UTC
Created attachment 12482 [details]
Attach as .sxw as this will be imported as a char attribute in the future.
Comment 4 caolanm 2004-01-14 15:18:58 UTC
Created attachment 12483 [details]
last attachment was the wrong one, this is the right one
Comment 5 caolanm 2004-01-14 15:28:12 UTC
Implemented for 2.0 in workspace hiddentext.

cmc->mru: I'm really not sure about backporting this to 1.1.2, hidden text is a
ke y feature, but its on the 2.0 PCD. I *can* backport this feature of exporting
the writer hidden text field as word's hidden text character attributes to 1.1.2
but I'm not sure that I should add such things to 1.1.2, but if you really think
I should do it for 1.1.2 then theres no problem, just send it back and I'll
commit it there as well.
Comment 6 michael.ruess 2004-01-15 09:39:17 UTC
You are right, the work shouldn't be done twice. As long as the export never
worked, the target OO 2.0 should fit well.
Comment 7 caolanm 2004-01-16 08:49:44 UTC
righteo, fixed in hiddentext for 2.0
Comment 8 caolanm 2004-01-21 11:21:36 UTC
reopen to reassign
Comment 9 caolanm 2004-01-21 11:22:10 UTC
cmc->sba: And good in hiddentext workspace for 2.0
Comment 10 caolanm 2004-01-26 10:46:00 UTC
*** Issue 24178 has been marked as a duplicate of this issue. ***
Comment 11 michael.ruess 2004-02-11 14:30:40 UTC
Checked "fix" in CWS hiddentext.
Comment 12 michael.ruess 2004-02-11 14:31:31 UTC
Verified. Fix will be included in OO 2.0.
Comment 13 guido.pinkernell 2004-02-12 12:33:31 UTC
*** Issue 17064 has been marked as a duplicate of this issue. ***
Comment 14 jack.warchold 2004-08-06 12:26:50 UTC
seen good in 680_m49-4
closing
Comment 15 oooforum (fr) 2019-07-22 10:05:56 UTC
*** Issue 4135 has been marked as a duplicate of this issue. ***