Issue 24314 - sql update for database in dBase format erase all fields but the ones updated
Summary: sql update for database in dBase format erase all fields but the ones updated
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 1.1
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: OOo 2.0
Assignee: marc.neumann
QA Contact: issues@dba
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2004-01-12 16:28 UTC by jmfayard
Modified: 2006-05-31 14:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jmfayard 2004-01-12 16:28:31 UTC
reproducible : always
Steps to follow :

*Create a database, use dBase file format, create a table "Address" with a few
fields (say Name, City, Email, Age)
* Enter a few entries
* Execute this SQL statement :
   update Address set Name = 'John Doo', Age = '35' 

* Result : the Name and Age fields are modified as they should
         but all the other fields (City, Email) in the updated entries are erased

Workaround : I did a trivial perl script to do the same thing for the same
database, all worked fine

$ cat perl_sqlupdate.pl
#!/usr/bin/perl
use DBI;
use DBD::XBase;
my $dbh = DBI->connect("DBI:XBase:/autre/adresses")
                            or die $DBI::errstr;
my $sth = $dbh->prepare("update Adresses set PrefixeTel = '+33' ")
                            or die $dbh->errstr();
$sth->execute() or die $sth->errstr();
Comment 1 alex.thurgood 2004-01-12 16:40:45 UTC
I can confirm this on OOo 1.1.0 US, Linux Mandrake 9.2. Setting oooqa. This is
an important bug as it leads to data loss/corruption. We ought to up the
priority: Frank what do you think ?

alex
Comment 2 alex.thurgood 2004-01-12 16:44:20 UTC
In addition, since dBase is currently the default db format for OOo (at least
until 2.?), it is unlikely that many users will have the capability to write
Perl scripts like the one proposed for the workaround.

alex
Comment 3 Frank Schönheit 2004-01-13 08:01:14 UTC
I suppose P3 is sufficient. Given that nobody ever complained about it ... (and
the dBase code is virtually unchanged for years). Nevertheless, we should
probably fix it for 2.0.
Comment 4 ocke.janssen 2004-01-29 11:32:26 UTC
fixed in cws oj08 
dba/connectivity/source/drivers/file/FStatement.cxx 1.30.36.1
Comment 5 hans_werner67 2004-02-02 12:47:37 UTC
change subcomponent to 'none'
Comment 6 ocke.janssen 2004-02-02 14:12:15 UTC
just execute a Update statement by hand.
Comment 7 marc.neumann 2004-02-25 13:03:37 UTC
set to fixed
Comment 8 marc.neumann 2004-02-25 13:03:51 UTC
set to fixed
Comment 9 marc.neumann 2004-02-25 13:04:10 UTC
verify in CWS oj08
Comment 10 grsingleton 2004-02-26 21:19:41 UTC
I would like to add that the problem does not exist in 1.1.1b
Comment 11 marc.neumann 2004-04-27 10:19:15 UTC
Hi,

fixed in current developer build -> close.
The current developer build can be found at
http://download.openoffice.org/680/index.html
Feel free to reopen if this issue is not fixed in the developer build.

Bye Marc