Issue 24719 - include images when pasting HTML content
Summary: include images when pasting HTML content
Status: CLOSED DUPLICATE of issue 37652
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 2.0.3
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2004-01-22 15:42 UTC by floeff+ooo
Modified: 2013-08-07 14:38 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description floeff+ooo 2004-01-22 15:42:20 UTC
OpenOffice.org should include images when pasting HTML content. It works fine
when doing it with Word, but not with OpenOffice.org.
Comment 1 h.ilter 2004-01-26 12:49:24 UTC
HI->EA: I think it depends from the browser isn't it?
Comment 2 eric.savary 2004-01-26 15:22:10 UTC
What do you exactly do?
Do you select the whole content (including images) of a web page in a browser,
copy it and paste it into OOo?
Comment 3 floeff+ooo 2004-01-26 18:44:36 UTC
Exactly!
Comment 4 eric.savary 2004-01-29 11:21:53 UTC
Can you please explain more precizely what you do, what you exactly see, if this
happens with a special URL, etc.
I can't reprosuce it.
Comment 5 floeff+ooo 2004-01-29 14:40:59 UTC
I have a website, that has styles, images, etc. and I would like to have that
website in OpenOffice as SXW document. Everything, including images, should
already be embedded.

Works fine with Word, but not with OpenOffice.
Comment 6 eric.savary 2004-01-29 15:57:38 UTC
Sorry but this description still lack precision.
If I copy paste Web content from a browser into OOo, I get this content
(including graphics) correctly pasted in OOo.
So please, once again, describe *step by step* what you do, get and expect. 
Comment 7 floeff+ooo 2004-01-29 16:18:49 UTC
I copy content from a protected (i.e., PHP session ID or cookie protection)
website. The text and style is allright, but the graphics not.

I only see placeholders as the graphics cannot be opened. Of course, OOo is not
logged on to that specific website. So it slows down OOo as it tries to open
every single image from the net instead of embedding it out of the clipboard.

MS Word seems to use other technique, as it embeds the graphic directly into the
document. That's what I would like to have as well. EMBED it into the document,
without having to load it from the website, and without having to manually
resolve the links.
Comment 8 eric.savary 2004-01-29 16:44:55 UTC
ES->SBA: I don't think MS-Word makes something else as OOo. It may just retrieve
the content faster from the cache/clipboard as we do (especially when no or
wrong proxies are set in OOo's options).
You are already involved in this proxy issue. Please close as duplicate are
escalate this enhancement as a "workaround" of a well known "design bug".
Comment 9 floeff+ooo 2004-01-29 16:58:47 UTC
Maybe OOo has other clipboard functions as Word does, because it has to support
more than one operating system?

The proxy stuff cannot work if the page is protected! OOo has no access (because
of missing credentials) to that page!
Comment 10 stefan.baltzer 2004-04-19 00:44:54 UTC
SBA->floeff: How about an URL?
Riddling about "being different in general" doesn't get us much further. We all 
heard about MS' browser integration even in the operating system itself and we 
shall not stir THAT stuff up again.
As a workaround for your very case, put that stuff into MS Word, save the file 
and open it in OOo in case the way to get there (tothe very content) is too 
secret to make us reproduce.
Set to "Worksforme" because (as ES stated above) copy-paste works in "everydays 
cases".
Comment 11 floeff+ooo 2004-04-19 20:35:03 UTC
The problem is that this is a database I can only access via my unversity
account, which I am not allowed to publish anywhere ;-(

I could send you a generated DOC file (from MS Word XP) of the page, does that
help you?
Comment 12 stefan.baltzer 2004-04-25 00:06:06 UTC
SBA-Floeff: Give it a try...
Comment 13 floeff+ooo 2004-04-25 10:04:06 UTC
I am not allowed to post them here, because of copyright issues. May I send it
as an attachment via e-mail to you?
Comment 14 stefan.baltzer 2004-04-26 22:10:49 UTC
SBA->Floeff: Yes. It will be treated as confidential as a "customer of SUN" 
bugdoc. Doing so is part of my work contract and if it has to be done like this 
in an "OOo.org case" in order to track down a defect, we may do it like this.
Reopening issue.
Comment 15 stefan.baltzer 2004-04-28 11:55:38 UTC
SBA->ES: As discussed, back to you.
Comment 16 eric.savary 2004-04-28 15:50:21 UTC
ES->BH: request: a clipboard option to paste linked content as embedded content.
Comment 17 floeff+ooo 2006-06-29 12:31:34 UTC
Any news on this one?
Grabbing web content into ODF is still very annoying when always having to
manually embed images
Comment 18 lohmaier 2007-02-03 01:39:20 UTC
duplicate issue 37652 comes straight to the point - no need to read confusing
comments :-)

*** This issue has been marked as a duplicate of 37652 ***
Comment 19 lohmaier 2007-02-03 01:39:43 UTC
closing duplicate