Issue 24990 - Q-PCD EaseOfUse-57 separate OOo modules: Options
Summary: Q-PCD EaseOfUse-57 separate OOo modules: Options
Status: CLOSED FIXED
Alias: None
Product: ui
Classification: Code
Component: ui (show other issues)
Version: OOo 1.1
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: OOo 2.0
Assignee: matthias.mueller-prove
QA Contact: issues@ui
URL:
Keywords:
: 24988 24989 24991 (view as issue list)
Depends on:
Blocks: 25893
  Show dependency tree
 
Reported: 2004-02-02 12:55 UTC by ivwhiting
Modified: 2004-12-29 14:53 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ivwhiting 2004-02-02 12:55:42 UTC
The current Tools -> Options window uses an unattractive and clutered layout. It
would be a huge usability enhancement if the window was to use a tabbed page
layout (similar to other office applications).  It would make navigating the
options easier, especially for those that are coming from applications from the
redmond giant.

To help reduce the number of options visible and enhance the layout further,
options that are applicable to other OOo components, such as impress should not
be visible from the writer application. The reduction in the number of options
to only those that are relevent to the current application should increase the
usability of the application.
Comment 1 wolframgarten 2004-02-02 13:01:35 UTC
Reassigned to Bettina.
Comment 2 wolframgarten 2004-02-02 13:03:24 UTC
*** Issue 24991 has been marked as a duplicate of this issue. ***
Comment 3 frank 2004-02-02 13:20:56 UTC
*** Issue 24989 has been marked as a duplicate of this issue. ***
Comment 4 frank 2004-02-02 13:23:08 UTC
*** Issue 24988 has been marked as a duplicate of this issue. ***
Comment 5 frank 2004-02-02 13:25:10 UTC
Hi Mathias,

Bettina told me that this is your construction site.

Frank

Comment 6 rblackeagle 2004-02-02 17:39:05 UTC
The "Tab" idea would be consistent with the Styles dialogs, so I would have no
problem with that; however, I use Tools > Options to set up the system for
clients for all their uses and would really object to having to open a new
document in each application simply to set the options for them.  In face, I
would vote strongly against such a clumsy arrangement.
Comment 7 ivwhiting 2004-02-03 08:49:27 UTC
Crowding the user with too many options is a problem. If the redmond giant did
the same with its applications and placed all the options for each of its office
applications within a single office application it would suffer a huge backlash
from the community with regards to useability. 

I don't see the problem with only giving the user options that are relevent to
the program that they are currently using. If you have a user creating a letter
in writer they will not want to see options for calc crowding their screen and
making things look more complex.
Comment 8 rblackeagle 2004-02-03 14:36:26 UTC
Tools > Options is a way for users to cutomize the way their applications work.
 Your second suggestion (context sensitive Options) could easily lead to this
type of complaint:  "I fixed my options on printing, but when I opened <file> it
wasn't set.  What do I do?"   This could easily happen with users who set the
options for Writer but don't have the same ones set for, let us say, Calc or
Presentation.  Now we've got additional complaints we don't need.

Having followed the bugs list for two years, I have yet to see this appear as a
problem for anyone.  It doesn't crop up in the discussion list, either. 
However, I like the idea of tabs, simply because of consistency.

Even without it, I have never known anyone to get confused about it.
Comment 9 matthias.mueller-prove 2004-02-03 15:02:59 UTC
This issue is covered by our product concept document to separate the OOo
modules. The spec is 
http://specs.openoffice.org/appwide/separate_modules/OptionsDialog.sxw 
Comment 10 matthias.mueller-prove 2004-02-03 15:06:01 UTC
set target to OOo2
Comment 11 matthias.mueller-prove 2004-02-03 15:12:10 UTC
parent bug ID changed
Comment 12 matthias.mueller-prove 2004-02-03 15:14:34 UTC
new summary
Comment 13 matthias.mueller-prove 2004-02-26 11:03:10 UTC
the spec status changed to "approved by i-Team"
http://specs.openoffice.org/appwide/separate_modules/OptionsDialog.sxw 
Comment 14 matthias.mueller-prove 2004-02-26 11:57:50 UTC
created child tasks for string review, impl, testplan, QA and documentation
Comment 15 matthias.mueller-prove 2004-12-29 14:52:51 UTC
all subtasks are fixed & closed
Comment 16 matthias.mueller-prove 2004-12-29 14:53:23 UTC
and closed