Issue 2517 - Display of Bookmarks in Document
Summary: Display of Bookmarks in Document
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: ui
Classification: Code
Component: ui (show other issues)
Version: current
Hardware: All All
: P3 Trivial with 42 votes (vote)
Target Milestone: AOO PleaseHelp
Assignee: requirements
QA Contact: issues@ui
URL:
Keywords:
: 22290 35308 (view as issue list)
Depends on:
Blocks:
 
Reported: 2001-12-12 10:23 UTC by pmuet
Modified: 2017-05-20 09:26 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description pmuet 2001-12-12 10:23:27 UTC
hi
I'm really new to this, so I hope I am doing this the right way...
I think it would be a good idea to add the following option to the display 
properties:
an option to display some kind of symbol in the text, where there is a bookmark 
defined
This would make it a lot easier to find out wheter you have inserted a bookmark 
at a specific place, rather than having to go through with the navigator to 
find out (especially if there are a lot of bookmarks defined in the document)

Thank you, I really appriciate the work you are doing
Pascal
Comment 1 stefan.baltzer 2001-12-12 11:23:11 UTC
Reassigned to Falko.
Comment 2 falko.tesch 2002-01-02 10:47:15 UTC
This issue is re-assigned to Christian Jansen for further evaluation.
Comment 3 christian.jansen 2002-01-08 14:32:13 UTC
Yes, it make sense to visualize bookmarks within the document, but
only without destroying the layout. I would propose an entry in the
"View" menu where those things could be toggled on or off.
Comment 4 christian.jansen 2003-06-24 09:15:53 UTC
I like the idea of displaying bookmarks. Is this a thing which fits
into the 'Document Map'?
Comment 5 matthias.mueller-prove 2003-06-24 09:29:40 UTC
let's see what we can do for OOo2
Comment 6 matthias.mueller-prove 2003-09-24 12:14:39 UTC
I like the idea, though it is not realistic that we implement
something for OOo2.0
Bettina, can you please keep track of this RFE.
Comment 7 ingenstans 2005-11-23 16:38:53 UTC
Just to say that I have written for my own use a macro that underlines all 
bookmarked text, for this very purpose. It's something to have found a 
workaround a for a bug four years old and still untouched. 
Comment 8 aziem 2005-12-28 14:28:20 UTC
*** Issue 35308 has been marked as a duplicate of this issue. ***
Comment 9 Oliver Specht 2007-02-16 19:40:33 UTC
*** Issue 22290 has been marked as a duplicate of this issue. ***
Comment 10 cno 2007-11-01 16:32:14 UTC
added myself as cc
By the way: P5 is rather low.
In a situation where bookmarks are used for information / navigation (with or
without automation), and a user can remove them just without seeing them ...
Comment 11 gregorhagedorn 2007-11-04 11:49:35 UTC
Please do resolve this issue... I am just trying to see whether I can at least
partly switch from MS Word to OpenOffice, and this is one of the first things I
stumble upon. I use Bookmarks and Bookmark references (text as well as page
number) a lot in most documents I write. I really need to see the places in the
text. The navigator is fine for debugging, but not for writing the text.
Comment 12 gregorhagedorn 2007-11-04 11:53:12 UTC
I separately read that showing bookmarks (which should be optional, of course)
should not impede layout. Microsoft Word does have a fairly usable solution for
this, by surrounding the bookmark with very narrow, slightly higher, gray
brackets ([]). I hope this can be replicated in OpenOffice.
Comment 13 cno 2007-11-04 21:26:42 UTC
Hi Gregor,

I don't really understand what you mean with 'The navigator is fine for
debugging, but not for writing the text.' But you may also try rightclick on the
page numer position of the statusbar to find the bookmarks.
For the rest: I know work with bookmarks is on it's way, so be ashured it will
be done somewhere the next year (my guess ;-) )
Comment 14 gregorhagedorn 2007-11-05 10:55:44 UTC
I don't really understand what you mean with 'The navigator is fine for
debugging, but not for writing the text.' But you may also try rightclick on the
page numer position of the statusbar to find the bookmarks.

My use of "debugging" was loose, I mean a work where a completely written
document  has some parts where the bookmark references are wrong. The navigator
is very good for such activities, but in my opinion less so for the process of
creating bookmarks/references directly while writing the text. Having no
indication about the presence of position of bookmarks while working on the text
itself is, as someone else described it, like "flying blind".
Comment 15 cno 2007-11-05 11:09:56 UTC
Hi Gregor,
Thanks. Now I understand.
I agree that in those situations it is very unpleasant that bookmarks are not
vissible.
Comment 16 oharboe 2008-05-28 07:35:28 UTC
Any chance of the target milestone for this being moved forward?

This is the only thing that I need to ditch Microsoft Word! :-)
Comment 17 rupxamqon 2008-11-26 14:37:56 UTC
I'd like to support this request. It is far to easy to delete a bookmark without
noticing when working in the text.
How about:
1. Inserting a little yellow mark - like the note (annotation) mark in OOo 2.4
2. Inserting an option to turn on or off display of this marks
3. And making it somehow more difficult to delete bookmarks (with an optional
pop-up warning, e.g.)
Comment 18 crossoverint 2009-01-07 12:13:24 UTC
I am hoping this available really soon. I have a bunch of people working for me 
who need to see bookmarks placeholders in the documents they work on. 
Appreciate the effort being put in to this.
Comment 19 rupxamqon 2009-02-14 03:53:16 UTC
As a temporary solution, I wrote an OOo Basic macro which inserts a note for
each bookmark, showing its position, name, and eventually the text at which it
is anchored.
It is published as OOo extension:
http://extensions.services.openoffice.org/project/VisibleBookmarks

But I continue to support the request for a better solution for this old problem...
Comment 20 cno 2009-02-15 09:20:06 UTC
@rup.xamqon: thanks for the extension!
Cor
Comment 21 rupxamqon 2009-02-15 23:03:21 UTC
@Developers: I think there are at least 2 problems here:

1. Visibility of bookmarks (see my extension, or my previous suggestion about
inserting a little mark like the Note mark in OOo up to 2.4).

2. Unlike e.g. notes or conditional hyphens, bookmarks are not noticeable for
cursor movement or when deleting: Move the view cursor one character at a time
over some text with a note or cond. hyphen inserted, and you have to move it
once more for it (with the cursor not advancing, because it is non printing). If
you move the view cursor one character at a time over text with a bookmark
inserted, you won't have to move the cursor once extra for the bookmark.
Maybe that is the reason why it is so easy to accidentally delete bookmarks
without noticing.

Suggestion: make bookmarks visible, and their cursor behaviour like the
behaviour of notes and conditional hyphens.
Comment 22 kwedeer 2009-03-13 15:50:31 UTC
Hi,

I strongly encourage to implement this feature, because it makes OO more 
interesting for businesses (I guess, ordinary users are not much interested in 
features beyond simple typing). It could greatly improve processing of forms 
and reports. If user is allowed to see the bookmarks of OO template (provided 
by software vendor), then he or she can customize this template easily. 
Comment 23 bettina.haberer 2010-05-21 14:40:51 UTC
To grep the issues easier via "requirements" I put the issues currently lying on
my owner to the owner "requirements". 
Comment 24 confindustria_vicenza 2010-11-08 15:18:40 UTC
The Industrialists Association of Vicenza uses bookmarks in conjunction with 
Lotus Domino databases. Bookmarks work fine but users cannot realize when they 
accidentally delete a bookmark.
We strongly encourage to implement this feature.