Issue 25369 - Enhancements for playing Videos
Summary: Enhancements for playing Videos
Status: CONFIRMED
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1
Hardware: PC Windows 2000
: P2 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needhelp, oooqa
Depends on:
Blocks:
 
Reported: 2004-02-11 14:21 UTC by mneumann
Modified: 2013-02-07 22:41 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mneumann 2004-02-11 14:21:40 UTC
There are several enhancements necessary for video import and playing. Besides
the fact that .avi clips don't seem to work, the Quicktime player needs some
improvement as well. First the performance is bad when loading the file. It
takes several seconds  just to get a video started. Then the video can't be
resized. If you reduce the size with the handles it will crop, if you enlarge it
will stay the same size. Then Quicktime does take the full control over the
keyboard. You can only start and stop the video, but you can't change the slides
anymore. Even pgUp and pgDown do not work anymore. So all these problems
together make the current video player practically useless. A more robust
solution similar to Powerpoint would be very useful, although Powerpoint can
handle only the .avi format and up to a resolution of 320x200. If you could
manage somehow to play .avi, Quicktime and Flash in fullscreen mode, you would
be well ahead of Powerpoint and you would increase the creative possiblities of
Impress drastically.
Comment 1 wolframgarten 2004-02-11 14:25:22 UTC
Reassigned to Bettina
Comment 2 aziem 2006-10-22 23:55:09 UTC
This issue report has more than one problem:
1. "avi clips don't seem to work"
2. video performance
3. video resizing (a duplicate to issue 55885)
4. control of the keyboard
5. Starting and stopping videos vs. changing slides
6. Play Flash and QT in full screen

However, rule #1: "One problem - One issue"
http://qa.openoffice.org/issue_handling/basic_rules.html#one_per_issue

So, should this be issue closed as invalid?
Comment 3 mneumann 2006-10-23 09:31:17 UTC
As far as I see the reason for one issue per problem is, that issues will be
handled by several people. The bottom line from this issue is, that the handling
of videos needs to be totally reworked. I am listing just several reasons why
that is necessary. Do I see that correctly?
Comment 4 bettina.haberer 2010-05-21 14:57:09 UTC
To grep the issues easier via "requirements" I put the issues currently lying on
my owner to the owner "requirements".