Issue 25545 - WW8: Alignment in numbering label wrong in RTL
Summary: WW8: Alignment in numbering label wrong in RTL
Status: CLOSED FIXED
Alias: None
Product: Internationalization
Classification: Code
Component: BiDi (show other issues)
Version: 680m22
Hardware: All All
: P3 Trivial with 5 votes (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@l10n
URL:
Keywords:
: 34632 37901 (view as issue list)
Depends on:
Blocks:
 
Reported: 2004-02-16 13:01 UTC by sforbes
Modified: 2013-08-07 15:02 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
the file (40.00 KB, application/msword)
2004-02-16 13:02 UTC, sforbes
no flags Details
exmpale 2 (20.00 KB, application/msword)
2004-02-16 15:43 UTC, sforbes
no flags Details
simple bugdoc (30.00 KB, application/msword)
2004-08-09 13:23 UTC, frank.meies
no flags Details
proposed patch (2.62 KB, patch)
2008-11-04 13:46 UTC, alan
no flags Details | Diff
revised patch (2.84 KB, patch)
2008-11-14 06:34 UTC, alan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description sforbes 2004-02-16 13:01:24 UTC
Notice the attached MSword 2003 file:
It has a few numbered list with diffrent styles. Each list is indented, and
between the numeral and the first letter there is a space.

When importing into OO, that space is lost

OOo 680m22, windows 2003
Comment 1 sforbes 2004-02-16 13:02:00 UTC
Created attachment 13186 [details]
the file
Comment 2 sforbes 2004-02-16 15:42:36 UTC
another example. Notice also that the single digit list items are incurrectly
aligned, where the single digit is aligned under the 10ths digit in the dual
digit items
Comment 3 sforbes 2004-02-16 15:43:21 UTC
Created attachment 13195 [details]
exmpale 2
Comment 4 sforbes 2004-06-21 15:05:46 UTC
adding dina as cc
Comment 5 Dieter.Loeschky 2004-07-05 11:14:34 UTC
DL->MRU: Could you please handle this?
Comment 6 michael.ruess 2004-07-09 15:33:00 UTC
MRU->HB: the numbers are not right aligned in the labels after import. This
property has to be set automatically by the import.
Comment 7 michael.ruess 2004-07-09 15:36:05 UTC
changed summary.
Comment 8 frank.meies 2004-08-09 13:20:56 UTC
Looks like the numbering alignment attribute is not set correctly for RTL
paragraphs during the import.
Comment 9 frank.meies 2004-08-09 13:23:35 UTC
Created attachment 17011 [details]
simple bugdoc
Comment 10 frank.meies 2004-10-13 09:56:30 UTC
*** Issue 34632 has been marked as a duplicate of this issue. ***
Comment 11 andreas.martens 2004-12-03 08:43:24 UTC
Changed prio to 4
Comment 12 frank.meies 2004-12-10 10:12:04 UTC
*** Issue 37901 has been marked as a duplicate of this issue. ***
Comment 13 andreas.martens 2005-03-30 13:48:54 UTC
I raise the priority again but I've to retarget this issue to OOo later.
Comment 14 hrp8264 2007-01-27 21:29:39 UTC
I'm not sure I understand all of the problems mentioned below. When I try to
open the attached examples, I am asked to install Open Office.org, which is
already installed!
I do have a similar problem in Writer, without importing from Word or exporting
to Word (or any other programme). When I choose right alignment for numbering,
the alignment is correct, but there is no space between numbering and text.
OOWriter offers the possibility to add space, but then the right alignment
disappears! It would be nice if this could be fixed in the next version.
Comment 15 kaplanlior 2008-04-09 12:20:34 UTC
I can confirm the bug still exists with oo.org 2.4.0 on Debian.

Please update the bug version info and re-target it.

Thanks.
Comment 16 alan 2008-11-04 13:46:53 UTC
Created attachment 57696 [details]
proposed patch
Comment 17 alan 2008-11-04 13:53:35 UTC
I've submitted a patch to fix the alignment of numbering on MS doc import. Even
though numbering alignment is set in the constructor of WW8ListManager, I can't
set it there, since it is known only later, during pStyles->Import(), whether
the document's direction is RTL. So I added another function to be called after
pStyles->Import(), which resets the alignment of the numbering.

Please review, and set the issue status to fixed if OK.
Comment 18 openoffice 2008-11-10 16:13:45 UTC
Applied patch (DEV300_m32), but issue still present.

ayaniger: Perhaps the default page properties play a role? When I load
left_right_align.doc, IsRightToLeft() always returns false. Thus,
ChangeAlignmentForRtl() is never called.
Comment 19 alan 2008-11-14 06:34:22 UTC
Created attachment 57989 [details]
revised patch
Comment 20 alan 2008-11-14 06:37:15 UTC
ayaniger->hbrinkm:
Yes you are correct. This revised patch checks the text direction of the text
for each numbering group, and aligns the numbering accordingly.
Comment 21 openoffice 2008-11-17 13:20:02 UTC
Sending        source/filter/ww8/ww8par.hxx
Sending        source/filter/ww8/ww8par3.cxx
Transmitting file data ..
Committed revision 263722.
Comment 22 openoffice 2008-12-01 13:15:34 UTC
ready for QA
Comment 23 michael.ruess 2008-12-08 13:28:38 UTC
Verified in CWS hb12.
Comment 24 michael.ruess 2009-01-09 17:10:19 UTC
Checked fix in DEV300m38.