Issue 25744 - vertical borders of visible area of cropped picture shifted to the right during 'Export - Selection'
Summary: vertical borders of visible area of cropped picture shifted to the right duri...
Status: RESOLVED FIXED
Alias: None
Product: Draw
Classification: Application
Component: save-export (show other issues)
Version: OOo 1.1
Hardware: All All
: P3 Normal (vote)
Target Milestone: AOO Later
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-02-20 20:42 UTC by lohmaier
Modified: 2013-05-17 16:57 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.0.0
Developer Difficulty: ---


Attachments
sceenshot showing original image and exported results when crpping both sides (167.43 KB, image/png)
2004-02-20 20:45 UTC, lohmaier
no flags Details
same as above, but only right side cropped (204.83 KB, image/png)
2004-02-20 20:46 UTC, lohmaier
no flags Details
only left side cropped (160.03 KB, image/png)
2004-02-20 20:47 UTC, lohmaier
no flags Details
Sample document with source and result (34.42 KB, application/vnd.oasis.opendocument.graphics)
2013-05-16 16:36 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lohmaier 2004-02-20 20:42:46 UTC
When exporting an image that has been cropped within OOo draw, the cropping area
gets shifted to the right, i.e. there's more cropping on the left and fewer
cropping on the right side of the image. (I'll attach a screenshot showing
original document and result)

Steps to reproduce:
0) Open a new draw-document
1) Insert an image into the document (I chose citrus.jpg from the gallery)
2) Select the image and choose "crop" from the toolbar and choose a left and/or
right crop
3) Choose File|Export and save to jpeg, png or other format

Compare the original doc & the exported image and notice the difference.

When you only set a right cropping, the left keeps intact (as expected) but the
right margins is shifted to the right.
When you only set a left cropping, the left margin shifts to the right again...
Comment 1 lohmaier 2004-02-20 20:45:00 UTC
Created attachment 13323 [details]
sceenshot showing original image and exported results when crpping both sides
Comment 2 lohmaier 2004-02-20 20:46:17 UTC
Created attachment 13324 [details]
same as above, but only right side cropped
Comment 3 lohmaier 2004-02-20 20:47:55 UTC
Created attachment 13325 [details]
only left side cropped
Comment 4 wolframgarten 2004-02-25 14:37:44 UTC
Reproducible. Reassigned to Christian.
Comment 5 clippka 2004-03-01 15:36:04 UTC
image exports are for sven
Comment 6 sven.jacobi 2004-05-27 14:19:22 UTC
accepted.
Comment 7 Rainer Bielefeld 2013-05-16 16:36:53 UTC
Created attachment 80701 [details]
Sample document with source and result

I observe something similar with  server installation of  "AOO 4.0.0-Dev – English UI / German locale [AOO400m1(Build:9700) - Rev. 1482523 Rev.1482259 (2013-05-15)]" on WIN7 Home Premium (64bit)", own separate user profile
Comment 8 Rainer Bielefeld 2013-05-16 16:41:36 UTC
Back to CONFIRMED due to facts
This is not TRIVIAL, it makes Export of selections more or less unusable
I wonder what relation to "Bug 74211 - Exporting cropped image results in wrong area" might be.
Old screenshots seem to show that we are talking about "Export - Selection", so I amend Summary
Comment 9 Rainer Bielefeld 2013-05-16 17:30:15 UTC
Export (selection) result with Attachment 80701 [details] for Bug 25744 reminds me to that what I see when I do "Modify -> Convert -> To polygon' with the cropped source picture in the sample document. What ever that might mean.
Comment 10 Armin Le Grand 2013-05-17 16:57:38 UTC
ALG: After fixing #74211# I checked, added two pictures, cropped one right, one left and exported to JPEG (selection not flagged). To be sure I added vertical lines right/löeft of the cropped images -> all looks well.
@rainerbielefeld: Seems you were right with your assumption :-)