Issue 26135 - make ruler-items snap to configurable grid
Summary: make ruler-items snap to configurable grid
Status: CLOSED DUPLICATE of issue 2470
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on: 24070
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-04 21:59 UTC by smartweb
Modified: 2013-08-07 14:41 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description smartweb 2004-03-04 21:59:45 UTC
Other word processing programs, such as Word, can have rulers that snap to a
grid.  OOo should get an option to, so when you right click on the ruler you can
check or uncheck Snap to Grid from the context menu that currently only changes
the unit of measure.
Comment 1 h.ilter 2004-03-05 13:18:11 UTC
Reassigned to BH
Comment 2 lohmaier 2004-03-07 00:38:29 UTC
Do you mean that tabs should snap to the grid?
Or what elements should snap? Please provide more details. Thank you.
Comment 3 smartweb 2004-03-07 03:48:22 UTC
The tab markers and indent markers should snap to the hash marks on the ruler.
Comment 4 lleland 2004-04-06 11:21:30 UTC
We just started using this package and this is the first serious problem we've
run into. The ruler should have a context configurable snap grid, snap units,
and displayed units division count (10 divisions for a centimeter is great, but
10 divisions for an inch is just silly for anyone but an engineer). Everything
that can be placed or moved on a ruler should be snappable (snappish?). A
keystroke modifier during a drag should override the snap (like Alt/Meta). There
should be a means to display the current value of a non-snap drag (an in-ruler
mode, or a floating tool-tip). All hand-entered units should take and keep
whatever decimal precision entered - two digits, while fine for the screen, is
not usable for large scale printers used in engineering and scientific applications.

We consider the lack of a ruler snap a serious flaw since it directly affects
the productivity of anyone doing large amounts of data tables and positioned
elements. Currently it is simply impossible to make accurate adjustments to the
ruler since there is no snap grid, and the non-snap measurement is not displayed
as you drag. A 5 minute task with the mouse in MS-Word becomes an hour task with
paragraph dialogs in OpenOffice.

Related to this is the lack of a third control for the
hanging-indent/first-line-indent triangles. You cannot adjust the hanging indent
without the first line indent dragging with it, though you can adjust the first
line indent without the hanging indent dragging. MS-Word solved this with a
small rectangle (labeled “left indentâ€) below the hanging indent triangle that
moves both the hanging indent and first line indent markers. A similar solution
here would make like a lot easier for people.

Also related is the ability to select multiple tables and use the ruler
snap-grid to adjust the all the columns with the same index in one drag for each
column. A common problem is entering many tables of data without knowing what
the maximum size of each column will be. When you're done, you want to adjust
the size of each column for all the tables at once. Currently you have to find
the max column sizes by hand, and then change the table size, left and right
indent, and each column size using the table properties dialog for each table in
turn. A huge waste of time.

We consider these problems to be a critical impasse to data entry and management
productivity for OpenOffice, and we hope to see them addressed as a high priority.
Comment 5 lohmaier 2004-04-07 19:40:18 UTC
confirming issue. There is a seperate issue to have tab-stops snap in the ruler,
I put it in the depends-on field so it doesn't get lost.

Comment 6 jnoreiko 2005-04-06 17:05:51 UTC
Is this going to be fixed for 2.0?
Comment 7 mmenaz 2005-12-08 12:25:05 UTC
Please, don't forgive about this issue! Is really annoying not having a snap. On
my opinion it has not the need to be configurable, a reasonable snap value would
be enough (I guess 1mm). Now you can visually move ruler elements with a
precision of a 1/100 of millimeter! Something absurd. Having a millimiter snap
or just the snap used by M$ Word would be good. If someone wants more precision,
the visual way is not the right one, he has to set numerically, of course. If
you want a 5mm precision, just drag until you reach the half centimeter
indicator, that is not hard to find with a 1 millimeter snap.
I don't know the "insides" of OOo, but this is the "basic" of visual interaction
design, regarding a tool very used, and one of the first problems that a
reluctant "converter" from M$Office will protest against. It seems something
that does not requires too much programming efforts but has huge benefits in OOo
acceptance.
Comment 8 stefan.baltzer 2006-11-17 16:05:13 UTC
SBA: Duplicate.

*** This issue has been marked as a duplicate of 2470 ***
Comment 9 jnoreiko 2006-11-17 16:10:38 UTC
Issue 2470 looks totally unrelated.
Comment 10 stefan.baltzer 2006-11-17 16:20:31 UTC
SBA: Closed.
Duplicate of issue 24070!!! I don't know why it got set to 2470. As far as I
know, only LEADING zeroes do not count :-)