Issue 26405 - Page break for style does not get reset
Summary: Page break for style does not get reset
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2004-03-12 15:26 UTC by thehl
Modified: 2017-05-20 11:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Samble document (7.56 KB, application/vnd.sun.xml.writer)
2004-03-19 18:36 UTC, thehl
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description thehl 2004-03-12 15:26:08 UTC
I have copied and pasted text from Pagemaker 7.01 with styles. (I'm guessing
this would be RTF).

The styles for this application include "Heading 1" which has a column break
before in the text flow. This is not the problem.

The problem is that, for the text flow for this document to be correct, I need
to change the format of this to be a page break before. I alter this in the
style, but the styles that currently have Heading 1 do not change. I go to these
styles and click on Format/Default and it still does not change.

I then change the style to Default, click on Format/Default, then change it back
to Heading 1. Again, no change.

Therefore there does not seem to be a way to change from column breaks to page
breaks using the style sheets.

This would be one of those problems that's probably much harder to find than to
fix so I wanted to report it.

Thanks for a wonderful product!
Comment 1 flibby05 2004-03-19 12:28:11 UTC
hello,
thank you for using and supporting OpenOffice.Org!
Could you please attach your document in the state after you pasted the text
from PageMaker? This would make it a lot easier for reproducing.
Thank you,
Max Weber
Comment 2 thehl 2004-03-19 18:36:31 UTC
Created attachment 13944 [details]
Samble document
Comment 3 thehl 2004-03-19 18:37:04 UTC
I have attached a test document. Note that the styles in this document do not
have Heading 1 set to page break before.

Now attempt to reset the text "Introduction" using format->default. Check
format->paragraph->text flow. Now change to Default style and check again.
Change back to Heading 1 and check again. You should see what I'm talking about.

Thanks.
Comment 4 lc3 2004-06-28 16:12:13 UTC
Reproduced on Win XP Pro 2002 SP1, OOo 1.1.2
Reproduced on Win XP Pro 2002 SP1, OOo 2.0_680

Also note right click > default doesn't work either.
Comment 5 h.ilter 2004-06-29 09:25:53 UTC
Reassigned to ES
Comment 6 eric.savary 2004-10-24 15:27:33 UTC
ES->OS: when a paragraph has a column or page break defined (hard formatted in
the properties of this paragraph) and the style for this paragraph does not have
a break or has another kind of break, resetting this paragraph over "Format -
Default" does nothing.
Comment 7 Oliver Specht 2004-10-25 07:28:58 UTC
.
Comment 8 Marcus 2017-05-20 11:22:10 UTC
Reset assigne to the default "issues@openoffice.apache.org".