Issue 26823 - build a commandline option for pdf generation
Summary: build a commandline option for pdf generation
Status: CLOSED DUPLICATE of issue 12817
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1.1RC
Hardware: All All
: P4 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2004-03-22 15:34 UTC by taskbar
Modified: 2013-08-07 14:41 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description taskbar 2004-03-22 15:34:41 UTC
OO offers a very important feature to generate a pdf since it is the most 
secure method to communicate with others.

However, it would be nice to have a commandline option so I can built scripts 
to automate exporting jobs.

The commandline option should have a filename as import and another filename as 
optional output. If no output filename is given the same filename is used but 
with the pdf extention. After the exporting is done OO should end (unless 
afcourse a document is already opened).
Comment 1 mci 2004-03-23 09:58:30 UTC
reassigned to bh
Comment 2 lohmaier 2004-03-23 23:41:38 UTC
confirming.
You can use a macro to convert your documents, like available on
http://www.ooomacros.org/user.php#95532
or http://oooconv.free.fr/
Comment 3 taskbar 2004-12-02 23:03:22 UTC
Looking at the comments from "cloph" I was wondering if this means case closed 
or confirming that the issue will be picked up?

Note that the status is still on status new while it is submitted in march.
Comment 4 lohmaier 2004-12-02 23:50:23 UTC
This was meant as some kind of workaround. You can start the macro from commandline.

You can as well set up a PDF-"Printer" (that uses ghostscript or some other tool
to convert the printout to pdf) and specify the printer on the commandline to
"print" the document.

Personally I think that adding the possibility to specify an output-filename is
overkill/not worth it. (But I'm not involved in taking decisions or implementing)
Comment 5 lohmaier 2005-08-06 18:28:20 UTC
duplicate

*** This issue has been marked as a duplicate of 12817 ***
Comment 6 lohmaier 2005-08-06 18:29:37 UTC
closing duplicate.