Issue 27051 - Word Completion including "umlauted" characters fails on sparc/solaris
Summary: Word Completion including "umlauted" characters fails on sparc/solaris
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1.1RC
Hardware: Sun Solaris
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords: oooqa
: 31980 (view as issue list)
Depends on:
Blocks:
 
Reported: 2004-03-29 07:59 UTC by tunla
Modified: 2013-08-07 14:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description tunla 2004-03-29 07:59:51 UTC
Environment:

SUNBLADE 2000  ultrasparc III workstation 900 Mhz
Solaris  9  12-03 
SUN/GNOME 2.0  
OpenOffice 1.1.1 RC3  for sparc/solaris english/US  language variant.

Description:

I live in Sweden so I try to write swedish text from time to time :-)

With word-autocompletion turned on:
When a word with umlauted charaters  like " använda " and its derivatives 
like  "användare , använder , används " are entered , autocompletion 
is garbled into " anvndare anvnder ... "  
This seems to happend with most words that contains a single umlauted 
character and exists in the spelling-database..  Words with multi-umlauted
characters like " räksmörgås " is not garbled.

This Bug is also present in :
OpenOffice 1.1.0   Swedish Sparc/solaris 
StarOffice 7 "Product update 2" Swedish Sparc/Solaris 

 This Bug is not present in any OOo or staroffice port to MS-windows 
 that I have used to date.
 
I have reported this bug to SUN. And got this reply:

-------------------
Thank you for using our StarOffice Support Service.

The following solution to your support case number #14236 is:

Your question:
When using the AutoCompletion function together with umlauts in StarOffice[TM]
Writer then the words get garbled. (Swedish version on Solaris only)


Our answer:
The Support Service was able to reproduce this behavior under the inhouse
testing conditions. In order to have this problem corrected in one of the next
versions, it was forwarded to the StarOffice[TM] Quality Assurance and
Development teams for further testing.
------------------------

   Regards  
   Lars Tunkrans.
Comment 1 michael.ruess 2004-03-29 14:29:26 UTC
MRU->SBA: for you...
Comment 2 ingenstans 2004-07-07 17:37:54 UTC
since this has been confirmed, I am marking it as new. 
Comment 3 stefan.baltzer 2004-07-12 11:30:42 UTC
SBA->CP: See also internal b5017711. As stated in there, it looks like there is
a dependance to the Window manager and/or the use of IIIMP, affecting Linux and
Solaris only.
Comment 4 christof.pintaske 2004-07-13 15:17:58 UTC
cp->os: as discussed to you. Most probably a problem of sending characters by
ExtTextInput, and not by KeyEvent. Internal reference: b5017711
Comment 5 immanuelcrc 2004-08-03 03:09:02 UTC
I don't know what diacritical characters are, but I think I am also getting this
with apostrophes.

Type in we've in a document. Verify that it is in your list of autocompletion
words. Then type in we' and the word become weve without any enter to accept the
word. If you delete the we've entry in the autocompletion, the next time you
type we're it is okay, but then it gets re-added to your list and bingo, the
next time you've got weve with only typing we'

I am also posting this on issue 31980.

680m47 on Gentoo 2004.1 
Comment 6 Oliver Specht 2004-12-01 10:18:40 UTC
Cannot be reproduced in src680 m62
Comment 7 andreas.martens 2005-03-30 14:39:22 UTC
Closed.
Comment 8 stefan.baltzer 2005-06-30 16:32:32 UTC
SBA: Reopening issue. This still ocurs in 680m111 on Solaris.
SBA->OS: See also internal issue b5017711 that I will close as duplicate of this
one.
Workaround: setenv USE_XOPENIM in teminal before launching soffice.
I talked to US and PL about this. Please aks PL for further info.
Comment 9 stefan.baltzer 2005-06-30 16:37:41 UTC
SBA: For OOo 2.0, the default for word completion was set to 10 characters. 
A working example for this problem (in German) is: "zusätzlich" -> "zustzlich".
Comment 10 stefan.baltzer 2005-06-30 16:59:33 UTC
*** Issue 31980 has been marked as a duplicate of this issue. ***
Comment 11 Oliver Specht 2005-07-05 15:14:15 UTC
WordCompletion and extended text input use the same core structures. To solve
this conflict for OOo 2.0 the completion text for extended input is now always
shown as Tip

Extended input (like used for Chinese, Japanese etc. ) have the same conflict on
all systems.

Issue 51585 has been submitted as follow-up
Comment 12 Oliver Specht 2005-07-06 09:58:36 UTC
cws os65 can be found on cws03

re-open issue and reassign to sba@openoffice.org
Comment 13 Oliver Specht 2005-07-06 09:58:46 UTC
reassign to sba@openoffice.org
Comment 14 Oliver Specht 2005-07-06 09:58:50 UTC
reset resolution to FIXED
Comment 15 stefan.baltzer 2005-07-06 14:38:00 UTC
SBA: Reopened to reassign.
Comment 16 stefan.baltzer 2005-07-06 14:38:35 UTC
SBA: Reassigned to CGU.
Comment 17 stefan.baltzer 2005-07-06 14:39:26 UTC
SBA: Oops. Proceeded the wrong issue. Back to me ... :-(
Comment 18 stefan.baltzer 2005-07-06 14:40:06 UTC
SBA: Set back to FIXED.
Comment 19 stefan.baltzer 2005-07-06 15:03:29 UTC
SBA: Verified in CWS os65. 
Now the word completion proposal will switch to "Tip" when an umlaut (or
accented character) is entered. When the next "normal" character is entered, it
switches back to the "word extension" display again. When "show as Tip" is
checked in tools-AutoCorrect-WordCompletion, nothing changes at all (as there
never was a problem). 

By the way, Check "show as Tip" is the workaround for versions without this fix
(OOo 1.1.X).
Comment 20 stefan.baltzer 2005-08-04 16:53:59 UTC
SBA: OK in 680m122. Closed.