Issue 27206 - Font reverts to default when it shouldn't
Summary: Font reverts to default when it shouldn't
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1.1
Hardware: PC Windows XP
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-31 05:32 UTC by bryan000
Modified: 2004-04-07 16:24 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description bryan000 2004-03-31 05:32:18 UTC
While editing documents I noticed that the font kept switching back to the
default Times New Roman at 12pt when I hadn't set it to do so. I found this
strongly undesireable and couldn't find a bug report, so here it is. This bug
was also present in 1.1.0 (I can't verify in earlier builds as I'm on dialup)

1. Create a new text document in Writer
2. Click the Font dropdown list and select any font aside from the one you have
set as default. You may also select a new font size and/or style
3. Type a line of text
4. Press enter
5. Type another line of text
6. Use your arrow keys to position the prompt at the very end of your first line
of text
7. Press the Right arrow key
8. Font changes back to default font, size and style

I was also able to produce this bug in the OpenOffice HTML so please forgive me
if I've submitted this to the wrong category.
Comment 1 arineckaig 2004-03-31 08:22:12 UTC
*** Issue 27206 has been confirmed by votes. ***
Comment 2 rblackeagle 2004-03-31 18:02:50 UTC
This is, I believe, an artifact of the style usage.  You are likely using
Default paragraph styles.  When you go to the end of the paragraph, strangely
enough you are "out" of the region where the new font was set.  Now you will get
the font set in the Default paragraph style.  A workaround is to call up the
Stylist (Tools > Stylist) or F11, and set the Font to what you want inside the
Default / Modify dialog (right-click on "Default" under Paragraph styles).  This
changes the default font as well.

Another (far from obvious) workaround is to always end a paragraph with a
"Return" so that the next paragraph also has the font and only then go back to
change errors in the paragraph.

IMO, a correct behavior would be for the "move to end of last line" to continue
to use the same font.  I would think the assumption (in the program) would be to
continue with the font to the very end and not allow the "move" to get past the
(invisible) paragraph marker or whatever might be there.
Comment 3 h.ilter 2004-04-07 16:24:25 UTC
Works as designed, not a bug!

Please take a look to the online help "format; while typing" which I've paste it
here:
"Applying Text Formatting While You Type

To apply bold formatting:
1.Select the text that you want to format.
2.Press Ctrl+B.
You can also press Ctrl+B, type the text that you want to format in bold, and
then press Ctrl+B. If the word is at the end of a paragraph, you can also press
the right arrow when you are finished."
Comment 4 h.ilter 2004-04-07 16:24:52 UTC
closed