Issue 28023 - PPD files with multiple extensions not recognized
Summary: PPD files with multiple extensions not recognized
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 2.0
Assignee: Joost Andrae
QA Contact: issues@gsl
URL:
Keywords:
: 34141 (view as issue list)
Depends on:
Blocks:
 
Reported: 2004-04-20 13:50 UTC by philipp.lohmann
Modified: 2007-08-13 15:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description philipp.lohmann 2004-04-20 13:50:07 UTC
When trying to import a new PPD file with spadmin:
- name the file bla.ppd.PS (incidentally the naming patter of some CUPS releases)
- start spadmin
- add a printer
- import PPD file from the choose driver dialog
- back in the choose driver dialog the new printer is not visible even though
the file got copied

Reason: duplicate extensions confuse the PPD finding mechanism in
psprint/source/helper/ppdparser.cxx.
Comment 1 philipp.lohmann 2004-04-20 13:50:34 UTC
started
Comment 2 philipp.lohmann 2004-04-20 14:29:16 UTC
fixed in cws vcl21
Comment 3 philipp.lohmann 2004-04-23 14:20:00 UTC
pl->ja: please verify in CWS vcl21
Comment 4 philipp.lohmann 2004-04-23 14:20:29 UTC
fixed
Comment 5 Joost Andrae 2004-04-23 16:09:46 UTC
JA: verified within vcl21cws
Comment 6 Joost Andrae 2004-06-08 15:41:35 UTC
JA: closing issue
Comment 7 hdu@apache.org 2007-08-13 15:23:38 UTC
*** Issue 34141 has been marked as a duplicate of this issue. ***