Issue 28243 - Increase precision of distance measurements
Summary: Increase precision of distance measurements
Status: CLOSED DUPLICATE of issue 45593
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: requirements
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-22 21:46 UTC by Joe Smith
Modified: 2013-08-07 14:41 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Joe Smith 2004-04-22 21:46:00 UTC
Entry of distances and sizes is rounded to two decimal digits, apparently by the
entry widgets.  E.g. entering a page margin of 0.625" is immediately rounded to
0.63".  In most cases this is sufficient, however, there are times when
increased precision is required.  One is when setting up a page of labels, or a
page-sized table with many rows/columns.  In these cases, the row height or
column width or cell margins are _multiplied_ across the page, so that a
systematic error of 0.005" can accumulate to 0.1" over 20 rows.  That's enough
to ruin the alignment with a sheet of labels.

I have worked around this by manually adjusting the individual rows, but this is
extremely tedious and error prone.

I suppose increased precision could be obtained by using smaller base units
(0.005 mm is a smaller distance error than 0.005 inches), but again this is very
inconvenient.  Well, now that I check, there seems to be some lower-level limit
on precision, as I can change the display unit to mm, and measurements are
displayed to two places, but once the change is committed to the document, it
gets truncated.

If possible, why not allow the user to enter as many digits as desired, and
preserve this in the document?
Comment 1 mci 2004-04-23 10:41:45 UTC
reassigned to bh
Comment 2 robertf 2006-10-20 22:37:55 UTC
Since issue 45593 has 14 votes, perhaps this issue should be marked as a
duplicate of that one. Or vice versa, since this one was opened first. I don't
know who can do it, but it would be good to merge them.

As noted in issue 45593, the problem applies to both Writer and Draw, and
probably other components, so the Component field should probably be changed.

I have just voted for this issue so at least its status should be upgraded from
Unconfirmed (I think).
Comment 3 johnwhardy 2006-12-20 09:16:31 UTC
I submitted issue #45593, which is a duplicate of this bug (or vice versa).
Either way, it would be nice to see some attention to it since it has not been
addressed under either issue number.

bh:

Please advise the status and plans. Thank you.
Comment 4 bettina.haberer 2010-05-21 15:15:57 UTC
To grep the issues easier via "requirements" I put the issues currently lying on
my owner to the owner "requirements". 
Comment 5 cno 2010-11-30 16:11:41 UTC
I mark this as dup of the newer issue 45593, since that issue has more cc's and
comments and dups

*** This issue has been marked as a duplicate of 45593 ***
Comment 6 cno 2010-11-30 16:13:13 UTC
and close