Issue 2856 - unable to edit cell with email address in
Summary: unable to edit cell with email address in
Status: CLOSED DUPLICATE of issue 22133
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: 641
Hardware: PC Linux, all
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-01-16 12:10 UTC by docb
Modified: 2017-05-20 09:53 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description docb 2002-01-16 12:10:46 UTC
Hi,
in an OO spredsheet, enter an email address. OO puts this into a different
format (grey background, looks like a hyperlink).
Anyway, dont make a typo, you are not able to change the address anymore.
Comment 1 frank 2002-01-16 14:28:59 UTC
Hi Axel,

I have to close it as INVALID.

Yes it's an hyperlink, no you are able to change this link in
different ways.

1. select the cell by moving the cell cursor with the cursor keys or
clicking into the cell at a not Link covered place.

2a. Select the hyperlink dialog either by clicking the Hyperlink
dialog Icon in the Iconbar or select Hyperlink from the Insert Menu.
Now change the content.

2b. select Default from the context menu of the cell and when set the
cell into Edit mode and change the content.
Best regards
Frank
Comment 2 frank 2002-01-16 14:29:40 UTC
closed as Invalid
Comment 3 docb 2002-01-16 15:31:14 UTC
 Hi Frank,
sorry to be a pest, but......
> 1. select the cell by moving the cell cursor with the 
cursor keys or
> clicking into the cell at a not Link covered place.

no, does not work -> the address remains as a block, you 
cant get the cursor in between to edit (neiter in cell, nor 
in the input line)

> 
> 2a. Select the hyperlink dialog either by clicking the 
Hyperlink
> dialog Icon in the Iconbar or select Hyperlink from the 
Insert Menu.
> Now change the content.

This works

> 
> 2b. select Default from the context menu of the cell and 
when set the
> cell into Edit mode and change the content.

does also not work, same as above.

I'm using 641c, it might be different in the cvs.
Current situation is somewhat unsatisfying....for a user its 
quite unclear that he is not able to edit it (or just via 
hyperlink)
Cheers
Axel 

Comment 4 frank 2002-01-16 16:21:17 UTC
Hi Axel,

Have you seen the Number 1 in front of select the cell...? This is
just to point out it's the first step. 

Point 2b is a different way to edit the such a link. Select the cell
as described in Point 1 and set the default cell style by choosing
default from the context menu. This changes the link to pure text.

Sure the CVS has more fixes, but I checked it with an 641C.

What's about the help ?

Search for 'hyperlink; editing' in the Calc Help. It describes how to
edit a hyperlink using the hyperlink dialog.

OpenOffice uses a different kind of User Interface to perform some
tasks as Microsoft Office does. No one said you have nothing to learn
using OpenOffice.

Frank
Comment 5 frank 2002-01-22 16:27:57 UTC
closed because Invalid
Comment 6 colin_grierson 2009-08-11 11:46:09 UTC
I hit this issue and thought it such a bad user design I was motivated to
register etc and report the issue. I see it's known and has been closed as
INVALID. I think this is a very poor decision. The way it works now makes for a
horrible user experience. No need to do this.

Colin
Comment 7 docb 2009-08-24 14:46:35 UTC
Colin,
I agree with your comment, I just came across that problem again (OO 3.1) and
still could not remember how to solve it. There is no 'edit hyperlink' or
something in the context menu, so this is even more complicated. Bad UI design.

Maybe you try to reopen? I did not succeed as you can see....

Best,
Axel
Comment 8 docb 2009-11-05 19:50:23 UTC
aaargh....I *always* get lost on this usability thing...and have to look up this
bug just to edit an email address. I still feel its bad design...therefor reopen.
Comment 9 oc 2010-03-16 08:59:14 UTC
reassigned
Comment 10 Rainer Bielefeld 2014-05-15 15:30:30 UTC
INVALID! If you want to edit a Hyperlink name (that's the text you want to modify) you have to start cell edit mode (<f2>), select all hyperlink, click Hyperlink icon in standard toolbar, modify "Name". 

Be aware of "Issue 76427 - selecting hyperlink right to left"

DUP of some kind of Enhancement Request "Issue 22133 - CALC, Draw, IMPRESS: Editing Hyperlink is too difficult; add context menu entry like in writer"

@all reporters, reopeners:
thank you for your feedback! Unfortunately you are wrong here, this is the AOO bug tracking system, not a helpdesk.
You can get assistance at
<http://user.services.openoffice.org/en/forum/>
or here:<http://www.openoffice.org/support/>
If you want to report bugs please consider hints on  <http://www.openoffice.org/qa/issue_handling/basic_rules.html>
Please feel free to reopen this Bug if discussion with other users leaded to an assessment that we have an AOO bug with a current AOO Version and a clear and comprehensible description how to reproduce the problem due to above mentioned guidelines. 
<http://qa.openoffice.org/issue_handling/pre_submission.html>, 
<http://www.openoffice.org/qa/issue_handling/basic_rules.html>  
<http://www.openoffice.org/bugs/bug_writing_guidelines.html>,
<http://wiki.openoffice.org/wiki/QA/HowToFileIssue>

*** This issue has been marked as a duplicate of issue 22133 ***