Issue 28708 - Search of users mailing list archive broken
Summary: Search of users mailing list archive broken
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Infrastructure
Classification: Infrastructure
Component: Mailing lists (show other issues)
Version: current
Hardware: All Windows XP
: P3 Trivial with 2 votes (vote)
Target Milestone: CEE Danube
Assignee: Unknown
QA Contact: issues@www
URL:
Keywords: oooqa
Depends on:
Blocks: 43784
  Show dependency tree
 
Reported: 2004-05-04 11:11 UTC by kelvine
Modified: 2017-05-20 09:42 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
28708 - autoresponse search (2.80 MB, image/bmp)
2005-03-18 00:06 UTC, Unknown
no flags Details
28708 - Kelvin - 2004 (88.23 KB, image/jpeg)
2005-03-18 00:07 UTC, Unknown
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kelvine 2004-05-04 11:11:12 UTC
Hi,

I have made this a P2 issue, however I feel it should even be a P1. We direct 
people to the archives, in the hope they will search for answers for questions 
they have.

However, the search feature is definitely broken.

I don't know about other archives, this issue applies to the 
users@openoffice.org archive.

Example 1. On the 24th of April I announced an autoresponse facility for 
moderated users. The word 'autoresponse' was in the subject.

Search for the word 'autoresponse' in the subject. Nothing is found.

This issue plus others should be found.

http://www.openoffice.org/servlets/ReadMsg?list=users&msgNo=63665

Example 2. On the date 2004-05-02 I sent three posts as the author 'Kelvin'.

Search for the word 'Kelvin' as the author. There are a large number found.

However, now use your browser Find feature (Control+F for Internet Explorer) 
and locate the entries for the year 2004. 

There is none.

One of these are:

http://www.openoffice.org/servlets/ReadMsg?list=users&msgNo=64240

Example 3. I've noticed a thread which contains the subject 'OOO logo'. 

For the sake of this example I go back through the archives and find the 
following issue which has the date of 30 May 2004.

http://www.openoffice.org/servlets/ReadMsg?list=users&msgNo=64288

This issue has the text 'OOo' without the quotes, in the body of the post.

A great number of messages are found. This message however is not found.

In summary, the one thing that appears to occur in all cases is entries for 
the year 2004 do not exist. I am not certain if that is the problem or not.

I do feel the archives in their current state, are unfortunately pretty 
useless if you want to search.

Hope this helps

Kelvin
Comment 1 flibby05 2004-05-04 11:24:55 UTC
keyissue might be:

>> In summary, the one thing that appears to occur in all cases is entries for 
>> the year 2004 do not exist. I am not certain if that is the problem or not.
Comment 2 stx123 2004-05-04 13:55:44 UTC
Hi, this looks like another duplicate to issue 1950, or?
The search works (sometimes) if you use the search from the left hand search box.
But it does not work if "Search mailing list archive" from the archive page is used.
Comment 3 kelvine 2004-05-04 15:57:03 UTC
Hi,

Is it related. Possibly.

Is it just the users mailing list archive, if it is, then it may be unrelated. 
If not, it may be generic and thus related.

Treat the issue as you see fit.

Regards

Kelvin
Comment 4 Unknown 2004-05-04 23:54:04 UTC
I created pcn28530 to have engineering take a look into this one.
Eric
Comment 5 Unknown 2004-08-13 15:28:05 UTC
We are seeing problems with the indexes potentially due to conflicting threads 
trying to access them simultaneously.  Investigating the thread problem now.

update timeframe: 08/20/04.
Comment 6 Unknown 2004-08-30 10:03:40 UTC
PB-DEF: Search fails on the mails archived during a certain period of time.
Comment 7 Unknown 2004-08-30 10:05:46 UTC
Updating whiteboard with additional PCN related to this issue.
Comment 8 Unknown 2004-10-29 21:22:51 UTC
*** Issue 32135 has been marked as a duplicate of this issue. ***
Comment 9 lohmaier 2004-10-29 22:37:28 UTC
issue 32135 is *not* a duplicate.
This issue is about search not returning all results. Issue 32135 is about no
search possible *at all* (it is disabled)
Comment 10 Unknown 2005-02-14 21:09:07 UTC
Updating WB. 
Issue actively looked into by engineering currently.
Comment 11 Unknown 2005-02-26 01:14:01 UTC
CN Engineering need to take the "indexer" down for 10-12 hours. They have 
setup the indexer on a separate box to copy the data and then re-index it over 
there and then re-populate the fixed index on the Openoffice box.

This coming Monday (Feb 28, 2005) is when we would like to do this starting 5-
00 PM PST. Approx. 10-12 hours later, the indexer should be up again.

Please update the ticket with your confirmation on this. 
Comment 12 stx123 2005-02-26 08:33:31 UTC
Please go ahead on Monday. We glad to hear if the process was successful.
Btw, why do we need to run this on a separate box?
Thanks, Stefan
Comment 13 Unknown 2005-02-28 19:41:46 UTC
Stefan, Work of this nature cannot be directly done on the live box.
Comment 14 Unknown 2005-02-28 19:42:11 UTC
Set to starting.
Comment 15 Unknown 2005-03-15 23:15:10 UTC
Stefan,

I have scheduled a re-indexing to start Wednesday, 3/16 @ 5:00pm Pacific.

Please update this issue if you believe the timing is a problem
Thanks
Comment 16 Unknown 2005-03-16 09:57:19 UTC
Assinging to Stefan for the response.
Comment 17 Martin Hollmichel 2005-03-16 10:44:28 UTC
the time is ok for us.
Comment 18 maison.godard 2005-03-16 11:19:13 UTC
if this impact the mailing lists availibility like what happend 2 weeks ago, it
should be advertised on them

Laurent
Comment 19 Unknown 2005-03-16 20:09:25 UTC
Laurent,

Will this impact the mailing lists availibility?

No. It won't impact mailing lists availibility. Users can send/receive mails and
can view mailing list archive etc. Only thing is, users can't search new mail
messages received/added during indexer's down time estimated to be between 10
and 12 hours.
Comment 20 Unknown 2005-03-17 19:55:34 UTC
The indexing is done.

Initial testing do not show any issue. We will further verify - ETA to complete
further testing: before Friday end of business.
Comment 21 Unknown 2005-03-17 19:58:49 UTC
Actually additional verification was completed while I was typing the previous
message.

Closing as fixed - Please close to confirm resolution or open if additional
question/issue
Comment 22 kelvine 2005-03-17 22:42:24 UTC
Hi,

If this is fixed then how come I still can't find the "autoresponse" example 
that I provided.

Regards

Kelvin
Comment 23 Unknown 2005-03-18 00:05:28 UTC
Kelvin,

Please provide the Test cases (Steps + Expected Result and Actual Result).

I tested the following:
Example 1:
---------
 => Entered "autoresponse" in Search box on the left hand side bar the result is
captured in attachement "28708 - autoresponse search"
It returned 197 mailing list.

Too reduce the result of the search I also searched for "Firstly, I would like
to say thanks to those who gave me encouragement" - It returned 6 search results
The fifth on the list is MSG 63665 identified in the steps you provided
(http://www.openoffice.org/servlets/ReadMsg?listName=users&msgNo=63665)

The more precise the search the least there are messages returned as I am sure
you know.

Example 2:
---------
 I also found a large number of results for this example: 2,989 search results
They are displayed 40 at a time, the "Ctr-F" only provides you a result if you
are displaying 40 in which 2004 is a valid date.
See attached "28708 - Kelvin - 2004" - The first 5 results are all from 2004 

I am not sure what the expected result was for Example 3.

I also look of "2004" it returned 179,622 search results. Some of the mailing
list were with dates in 2004, so it was not just 2004 in the subject or body.

Phil
Comment 24 Unknown 2005-03-18 00:06:10 UTC
Created attachment 23977 [details]
28708 - autoresponse search
Comment 25 Unknown 2005-03-18 00:07:20 UTC
Created attachment 23978 [details]
28708 - Kelvin - 2004
Comment 26 kelvine 2005-03-18 07:25:03 UTC
Hi,

The following is the process to repeat what I am finding.

Go to the OpenOffice.org website www.openoffice.org
Select -Mailing Lists at the left in the General links menu
Scroll down to the "General Mailing Lists" section
Click on the Search link for the users@openoffice.org list
In the Search for field enter "autoresponse" without the quotes
Click on the Search button leaving the drop down box as Search subjects

There are 12 entries shown. Only one is from Kelvin and if you click on the 
link it is the following message.

http://www.openoffice.org/servlets/ReadMsg?list=users&msgId=1330810

In my original issue note I mentioned the following message which appeared in 
the users mail list.

http://www.openoffice.org/servlets/ReadMsg?list=users&msgNo=63665

Entering the above link into the address field of my browser I see this 
message still exists.

The search I performed above does not display this message and I thought it 
should.

Hope this helps.

Kelvin
Comment 27 Unknown 2005-03-19 00:44:16 UTC
Kelvin,

I reproduce the error reported in Mailing List search function and we are
investigating this isssue (PCN 35626).

At this point I have the following workaround to offer:
 => Using the "Advanced Search" in the left hand bar you can narrow the research
to Mailing Lists. It searches all the mailing lists so it provides more results
that if you were narrowing your search to only "users@openoffice.org" - The
column "Posted to" indicates the mailing list where it was found.

Considering the workaround offered I will lower the Priority to P3. Please let
me know whether you think otherwise.
Comment 28 Unknown 2005-04-21 22:35:29 UTC
We need to schedule another task to fix the indexer issue.
The INDEXER on production box will be down for 15 - 20 hrs. Please let us know 
a suitable time (will Sunday night --pacific work?)

cc-ing louis, st, mh.
Comment 29 lsuarezpotts 2005-04-22 00:11:58 UTC
as I understand it, the effect of the indexer being down is that the mail system gets really slow, yes? 

FWIW, we are planning on moving to our new "look" Friday and probably some over the weekend, but I 
don't think that will affect things.

louis
Comment 30 stx123 2005-04-29 16:19:29 UTC
The weekend with the change of the webdesign to the new "look" went by and we
would be ready for another try.
Could you please let us know whether the indexer has impact on mail delivery?
If not feel free to go ahead at weekends. Please inform us about the end of the
indexer downtime and the expected timefrime the indexer will need to catch up.
Comment 31 bernhard 2005-07-17 11:26:03 UTC
Created attachment 27981
Comment 32 bernhard 2005-07-17 11:29:31 UTC
sorry for posting Screenshot to wrong issue - my fault
It should be attached to #51699

- can it be removed here?
Comment 33 lsuarezpotts 2005-07-25 22:26:08 UTC
it's probably easier to just ask people interested in this issue to ignore the mistaken attachment.

Louis
Comment 34 Unknown 2005-10-17 23:50:47 UTC
Stefan, The Indexer needs to be repaired again and we need to schedule with 
our PET team to fix this. AFAIK there is already another issue opened 
reporting this. I will update that issue too.
Comment 35 Unknown 2005-10-18 02:46:33 UTC
BTW, removed bedipp's attachment as per his request (on Sun Jul 17 03:29:31 -
0700 2005 ).
Comment 36 stx123 2005-10-19 21:19:25 UTC
Please move the run of th eindexer to next week. Feel free to run it between
11am and 9pm your time. A short notification would be appreciated though.
Comment 37 Unknown 2005-11-23 01:01:51 UTC
CN engineering decided to postpone this particular issue after the upgrade to 
Danube. This is due in a couple of months.
Comment 38 Unknown 2007-02-23 05:52:30 UTC
Verified that this issue has been fixed .

Please verify and close the issue .