Issue 288 - Page is not displayed
Page is not displayed
Status: CLOSED FIXED
Product: udk
Classification: Code
Component: documentation
613
All other
: P1 trivial (vote)
: ---
Assigned To: Unknown
issues@www
http://udk.openoffice.org/cpp/ref/cpp...
:
: 229 (view as issue list)
Depends on: 66
Blocks: 290
  Show dependency treegraph
 
Reported: 2001-01-11 11:46 UTC by Unknown
Modified: 2003-12-06 14:52 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2001-01-11 11:46:39 UTC
All pages in the cpp/ref subdirectories are not displayed, but I can see the 
pages, when I use "Browse Source". The URL for the index site is then 
http://www.openoffice.org/source/browse/udk/www/cpp/ref/cppu/index.html.

In the past the sub tree was removed direct from the server, because we had 
problems with upper and lower case. We checked it in in lower case, but then 
the pages are not displayed. CVS access is no problem.

I need the fix fast, because no one can access the information of functions and 
API's. So they don't know, what they should do.
Comment 1 stx123 2001-01-13 01:11:30 UTC
*** Issue 229 has been marked as a duplicate of this issue. ***
Comment 2 stx123 2001-01-13 01:18:27 UTC
Markus, you didn't intend to assign this issue to yourself, did you?
Should the owner be openoffice-admin@collab.net?
Comment 3 Unknown 2001-01-15 14:57:19 UTC
Yes, it should. I cannot write on the cvs server.
Comment 4 Unknown 2001-01-16 04:21:53 UTC
Markus,

I have made you the project owner of the UDK project, with full read and write 
privs to all modules.  You should be able to modify this document now.
Comment 5 Unknown 2001-01-16 11:18:44 UTC
Fine, so I can login to the www.openoffice.org cvs server and remove
the archives by myself. Which address can I use and
is my normal user name, password valid?
Comment 6 Unknown 2001-01-16 11:22:56 UTC
*** Issue 296 has been marked as a duplicate of this issue. ***
Comment 7 stx123 2001-01-19 13:12:29 UTC
Thanks for removing the old directories and giving Markus the appropriate 
rights. But still the problem is unresolved.
see another test URL:
http://udk.openoffice.org/cpp/ref/cppuhelper/f_weak.hxx.html

The generate page contains the following error message in the servlet generated 
HTML source
WARNING: Include: Error reading 
file /usr/local/tigris/data/helm/htdoc/udk/www//cpp/ref/cppuhelper/f_weak.hxx.ht
ml
We tried to
- remove CR in html files
- strip down the content

But this error occurs still in this file and in all directories in 
udk/www//cpp/ref/
Is there a unix permission problem?

Comment 8 Unknown 2001-01-19 20:53:11 UTC
Reassigning to Kat as first-level technical support.  Please escalate to npm or 
edk as necessary.
Comment 9 Unknown 2001-01-19 21:39:22 UTC
Just to be clear, in the line:

WARNING: Include: Error reading 
file /usr/local/tigris/data/helm/htdoc/udk/www//cpp/ref/cppuhelper/f_weak.hxx.ht
ml

is the double slash between the www and cpp a mistype?
Comment 10 stx123 2001-01-20 22:04:10 UTC
No, the // isn't a typo, but also not the reason for the problem. This appears 
in all projects and is tolerated by unix file systems.
Comment 11 Unknown 2001-01-21 05:14:10 UTC
Sorry, realize how the extra slash was added and that it is ignored. The
permissions look ok on the directory and files in question, have checked out and
commited the files again with no change. Reassigning to edk for further
investigation.
Comment 12 Unknown 2001-01-22 12:46:17 UTC
I think this is resolved now.  Somehow, the checked out version of the module
was seriously messed up.  /usr/local/tigris/data/helm/htdoc/www/udk/cpp/ref/CVS
was missing entirely (though "ref" was mentioned as a directory in
/usr/local/tigris/data/helm/htdoc/www/udk/cpp/CVS/Entries).

I became tigrisc (the uid used for these operations) and attempted to use the
command (from /cvs/CVSROOT/loginfo) which is used to update
/u/l/t/data/helm/htdoc. Its complaint about ref is sadly lacking details:
? ref

(This may have been visible during cvs commit operations for files anywhere in
udk -- but there are a couple other such messages for udk which aren't real
problems which would tend to hide it if so.)

So I moved the ref directory, I removed it from cpp/CVS/Entries, and I reran
that command -- at which point it pulled a bunch of files from CVS.

I'm not sure how or why the checked out version got into a bad state (though I
still have the directory, and wouldn't mind trying to figure out what went
wrong).

Please test and mark this closed if it is in fact fixed.

thanks
Comment 13 stx123 2001-01-22 13:10:54 UTC
It works now.
Thanks