Issue 29006 - WW6: all Polish Characters Garbled on Import
Summary: WW6: all Polish Characters Garbled on Import
Status: RESOLVED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 2.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: openoffice
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on: 103475
Blocks:
  Show dependency tree
 
Reported: 2004-05-10 22:29 UTC by milek_pl
Modified: 2013-08-07 14:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The example of a file garbled in OOO (59.50 KB, application/msword)
2004-05-10 22:30 UTC, milek_pl
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description milek_pl 2004-05-10 22:29:14 UTC
Polish characteres get garbled on import of .doc files from MS Word 6.0/95. OOo
wrongly supposes that all national characters in Word 6.0 files are in the
Western European codepage and translates them into western charsets. The result
is a garbled file. The same file opens perfectly in MS Word 2000/XP.
The issue makes import from Word 6.0 files quite unusable for Polish users. I
tested it on Ooo 1.1.0 and 1.1.1 in Linux & WinXP.
Comment 1 milek_pl 2004-05-10 22:30:12 UTC
Created attachment 15135 [details]
The example of a file garbled in OOO
Comment 2 michael.ruess 2004-05-11 07:20:51 UTC
MRU->MM: normally it works, but here is a case where some polish characters can
not be imported properly for WW6 format..
Comment 3 andreas.martens 2004-06-21 13:06:52 UTC
Because of a shortage of resources we have to retarget this issue to OOo later. 
Comment 4 martin_maher 2005-04-13 17:13:49 UTC
mmaher->flr: Yours I think
Comment 5 milek_pl 2006-12-06 18:54:41 UTC
still there :(
Comment 6 milek_pl 2006-12-17 13:32:14 UTC
duplicate of issue 67838
Comment 7 milek_pl 2007-03-05 13:37:24 UTC
correcting the description line, it's wrong; note that WW6 files are NEVER
imported correctly when they have non-Western character sets.
Comment 8 kpalagin 2007-04-06 10:51:56 UTC
milek_pl,
I think Russian derivative build of OpenOffice has solved this problem (it 
works just fine for me - see issue 67838). You can download OO 2.2 Pro from 
http://www.i-rs.ru/download and change Localle in Languages to Polish.
Comment 9 milek_pl 2007-04-06 14:29:51 UTC
Kirill, unfortunately this doesn't work for me. Could you test it with the file
attached? You should see Polish chars, i.e., if you cannot see a with a caron
(ogonek) at the end of the word, but a number 1 in superscript, it means it
doesn't work.

Anyway, the developers of this 'professional' version should commit patches here
for the rest of us :)
Comment 10 thackert 2008-09-14 18:23:49 UTC
Hello milek_pl,
I have tested your attached document under Debian SID/Experimental AMD64 with
OOo 3.0 RC1 and it seems, that this issue is fixed. But as I have no winblows
installed nor their fonts, it could be some kind of font substitution issue here
at my system ... ;) So it would be nice, if you could test it with the RC1 of
3.0. If it is fixed there, it would be nice, if the issue could be closed. If it
is not fixed, see this message as a reminder ... ;)
Comment 11 milek_pl 2008-09-14 19:29:33 UTC
thackert -> Just opened this doc in OOo 3.0 RC1 /Windows and fonts are garbled
as they were before. The problem is that OOo defaults to win-1251 or something
while reading this file.

I opened the file in MS Word 2007 (fonts displayed correctly) and saved in Word
6 format -> OOo 3.0 RC1 still garbles the fonts. For example, it displays "¹"
instead of "Ä…".
Comment 12 thackert 2009-12-28 08:48:20 UTC
Hello milek_pl,
as I am not able to read/speak Polish, I do not know, if I am of any help here,
but have you tested it with a newer version of OOo like OOO320m8? Does this
issue still occur there? And would you be so kind to attach a screenshot, how it
looks like in M$O as well as one from inside OOo? I think it would help us QA
guys, who are not able to read Polish otherwise ... ;)
Have fun
Thomas.
Comment 13 milek_pl 2009-12-31 16:26:31 UTC
@thackert: the easiest way to debug such issues is to use the Microsoft Word 
Viewer available for free from Microsoft.

Anyway, the issue is fixed in OOo 3.2 RC1 :) So I'm setting this as fixed.