Issue 29109 - suggestions for bibliography
Summary: suggestions for bibliography
Status: CLOSED DUPLICATE of issue 4260
Alias: None
Product: bibliographic
Classification: Code
Component: ui (show other issues)
Version: OOo 1.1.1b
Hardware: Mac Mac OS X, all
: P3 Trivial
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@bibliographic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-12 20:18 UTC by astack
Modified: 2004-05-19 22:44 UTC (History)
1 user (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description astack 2004-05-12 20:18:33 UTC
Hi, there's a lot of people who are complaining about the bibliography in OpenOffice, but since I 
couldn't figure out how to add suggestions to their comments, and since I have specific suggestions 
rather than just complaining, I just started a new issue.  I apologize ahead of time for containing 
several issues in one issue.  I have used the bibliography database several times to write professional 
publications and, while I find it very useful, it also can be very frustrating:

    1)  The references should have a formatting style attached to them, similar to the fields of the 
bibliography.  WIth, OOo 1.1, you all added the ability to not have brackets on the name, which is great, 
but what would be even better is if you let the user format the field in the same way the fields in the 
bibliography itself are done, so the user can make them italicized, bold, superscript, whatever.  E.g., I 
recently wrote a manuscript that I sent to a journal that used superscripted numbers without brackets 
as the references.  I ended up having to go through the manuscript and manually supercripting the 
numbers.  If a you could add a formatting-style type for the bibliography references as well as the 
bibliography, that would be great!  Just like the "Structure and Formatting portion of the "entries" tab in 
the "edit bibliography" dialog.

     2)  Multiple references.  One problem I have is if I reference several items at one time.  If I use 
numbers with brackets, this comes out looking like [1][2][3][4].  Most journals ask for [1-4] or [1,2] in 
the case of just two references.  Is there any way to accommodate multiple references?  The only thing I 
can do now is go in and replace the fields with text, but that screws up the numbering system so I have 
to replace all of the bibliography references fields with text.  Sorry but I can't suggest an easy way to do 
this, maybe even just adding a "combine references" option in the "Insert bibliography entry" dialog to 
add multiple references, and then somehow get the logic right for the separators.

     3)   Bibliography database manager.  I found that the default length of the fields in the database are 
too short for my use.  E.g., the "title" field has only 50 characters or somewhat, which is too short for 
some articles.  I created my own database file with a longer title field, but now the database manager 
doesn't recognize that field when I start it up, so I have to manually assign the fields.  Is there any way 
to make the database manager more forgiving of customized field lengths (or names)?

     4)   Bibliography database manager, management of multiple authors.  This one is complicated 
because it requires a lot of logic.  Basically, every journal has its own way of listing the authors, some 
do last name first, comma, initials, semi-colon, repeat with next author.  Others do no commas 
between initials and last name and commas separating the authors with an "and" separating the last 
author and the second to last author.  At first I tried creating customized fields for each author and 
their initials, but this runs into the #3 problem listed previously with the database manager not 
recognizing the fields as well as a problem with formatting the entries in the bibliography itself for 
numbers of authors.  It almost requires an if, then logic in the "Structure and Formatting" portion of the 
"Entries" tab of the "Edit table" dialog, so that if there is present_author+1, then put a delimiter, 
otherwise, go to the next field.  Right now I just manually edit the bibliography when doing my final 
formatting if the author entry in the database is formatted differently from what I need it to be.  This is 
another one that will take a lot of work to get it right (from what I remeber, EndNote is a pain in the 
neck with this also).

    Anyway, that's it, keep your stellar work on OOo.org!!!!!  Thank you very much!  I guarantee that 
academic types who publish a lot will want a developed bibliography program.  I find the limited one 
you do have to be very useful.  I have some limited programming experience so I'll look around and see 
if there's something I can do myself, but its pretty intimidating compiling openoffice and haven't had 
any luck so far.  Would it be possible to work on the database manager as a macro and avoid having to 
compile the whole program each time??  That way I could mess with it to see if I could fix some of these 
issues but not get in over my head.  Thanks.
Comment 1 astack 2004-05-12 22:54:18 UTC
Oops,  I just realized that number three listed here has already been addressed with 1.1.1 and is a 
duplicate of issue 16268.  Sorry for the trouble!
Comment 2 astack 2004-05-12 23:09:21 UTC
Hi, me again, I also realized that the problem I've listed as number 4) is very similar to issue 26885.  
There, the user wants to suppress the formatting surrounding empty fields.  If that were implemented, 
it would work for this case as well because I could use customized fields for the each author's last name 
and initials.

Thanks again.
Comment 3 dnwilson 2004-05-13 08:40:59 UTC
Thanks for the comments, we will take note of them. 
Have you seen the information about the Openoffice Bibliographic project at 
bibliographic.openoffice.org ? 
 
I have written a document explaining how to increase the db field sizes at 
http://bibliographic.openoffice.org/files/documents/124/1284/HOWTO-increaseFieldSizes-V1.0.sxw 
 
I shall make this issue as a duplicate of Bibliographic redesign project issue 
4260 
 
Also could rend you suggestions to the bibliographic project discussion list 
at dev@bibliographic.openoffice.org so more people will see them - thanks 
 
David Wilson 

*** This issue has been marked as a duplicate of 4260 ***
Comment 4 eric.savary 2004-05-19 22:44:57 UTC
closed