Issue 29191 - Deleting a data source kills OpenOffice
Summary: Deleting a data source kills OpenOffice
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 1.1.2
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: marc.neumann
QA Contact: issues@dba
URL:
Keywords: oooqa
: 29880 (view as issue list)
Depends on:
Blocks:
 
Reported: 2004-05-14 12:37 UTC by rsussland
Modified: 2006-05-31 14:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description rsussland 2004-05-14 12:37:11 UTC
I'm using the TechPreview2 package for Panther, although I've experienced the same problem on all 
previous versions of openoffice for mac. 

To reproduce:

1. first add a data source
2. Then delete the data source you added. It doesn't matter if the data source was added a long time 
ago or just now. It doesn't matter if the data source is a text file, or ODBC, or JDBC. 
3. If the connection is open, you will get an immediate freeze (see below.)
4. If the connection is not open, the data source will appear with a red check mark. In this case, the 
freeze happens when you hit "apply" in the Data source administration pane.

Definition of Freeze:
Well, everything is frozen! If I launch a terminal, I get 

"-bash: fork: Resource temporarily unavailable"

If I kill some apps (to get some more resources) I find that openoffice has spawned a large number of 
zombie processes, like so:

Hugo2:~ robert$ ps -aex | grep "soffice"
 1015  ??  S      0:13.59 /Applications/OpenOffice.org1.1.2/program/soffice.bin VAR-1= SHELL=/
 1053  ??  Z      0:00.00 (soffice.bin)
 1054  ??  Z      0:00.00 (soffice.bin)
 1055  ??  Z      0:00.00 (soffice.bin)
 1056  ??  Z      0:00.00 (soffice.bin)
 1057  ??  Z      0:00.00 (soffice.bin)
 1058  ??  Z      0:00.00 (soffice.bin)
 1059  ??  Z      0:00.00 (soffice.bin)
 1060  ??  Z      0:00.00 (soffice.bin)
 1061  ??  Z      0:00.00 (soffice.bin)
 1062  ??  Z      0:00.00 (soffice.bin)
 1063  ??  Z      0:00.00 (soffice.bin)
 1064  ??  Z      0:00.00 (soffice.bin)
 1065  ??  Z      0:00.00 (soffice.bin)
 1066  ??  Z      0:00.00 (soffice.bin)
 1067  ??  Z      0:00.00 (soffice.bin)
 1068  ??  Z      0:00.00 (soffice.bin)
 1069  ??  Z      0:00.00 (soffice.bin)
 1070  ??  Z      0:00.00 (soffice.bin)
 1071  ??  Z      0:00.00 (soffice.bin)
 1072  ??  Z      0:00.00 (soffice.bin)
 1073  ??  Z      0:00.00 (soffice.bin)
 1074  ??  Z      0:00.00 (soffice.bin)
 1075  ??  Z      0:00.00 (soffice.bin)
 1076  ??  Z      0:00.00 (soffice.bin)
 1077  ??  Z      0:00.00 (soffice.bin)
 1078  ??  Z      0:00.00 (soffice.bin)
 1079  ??  Z      0:00.00 (soffice.bin)
 1080  ??  Z      0:00.00 (soffice.bin)
 1081  ??  Z      0:00.00 (soffice.bin)
 1082  ??  Z      0:00.00 (soffice.bin)
 1083  ??  Z      0:00.00 (soffice.bin)
 1084  ??  Z      0:00.00 (soffice.bin)
 1085  ??  Z      0:00.00 (soffice.bin)
 1086  ??  Z      0:00.00 (soffice.bin)
 1087  ??  Z      0:00.00 (soffice.bin)
 1088  ??  Z      0:00.00 (soffice.bin)
 1089  ??  Z      0:00.00 (soffice.bin)
 1090  ??  Z      0:00.00 (soffice.bin)
 1091  ??  Z      0:00.00 (soffice.bin)
 1092  ??  Z      0:00.00 (soffice.bin)
 1093  ??  Z      0:00.00 (soffice.bin)
 1094  ??  Z      0:00.00 (soffice.bin)
 1095  ??  Z      0:00.00 (soffice.bin)
 1096  ??  Z      0:00.00 (soffice.bin)
 1097  ??  Z      0:00.00 (soffice.bin)
 1098  ??  Z      0:00.00 (soffice.bin)
 1099  ??  Z      0:00.00 (soffice.bin)
 1100  ??  Z      0:00.00 (soffice.bin)
 1101  ??  Z      0:00.00 (soffice.bin)
 1102  ??  Z      0:00.00 (soffice.bin)
 1103  ??  Z      0:00.00 (soffice.bin)
 1104  ??  Z      0:00.00 (soffice.bin)
 1105  ??  Z      0:00.00 (soffice.bin)
 1106  ??  Z      0:00.00 (soffice.bin)
 1107  ??  Z      0:00.00 (soffice.bin)
 1108  ??  Z      0:00.00 (soffice.bin)
 1109  ??  Z      0:00.00 (soffice.bin)
 1110  ??  Z      0:00.00 (soffice.bin)
 1111  ??  Z      0:00.00 (soffice.bin)
 1112  ??  Z      0:00.00 (soffice.bin)
 1113  ??  Z      0:00.00 (soffice.bin)
 1114  ??  Z      0:00.00 (soffice.bin)
 1115  ??  Z      0:00.00 (soffice.bin)
 1116  ??  Z      0:00.00 (soffice.bin)
 1117  ??  Z      0:00.00 (soffice.bin)
 1118  ??  Z      0:00.00 (soffice.bin)
 1119  ??  Z      0:00.00 (soffice.bin)
 1120  ??  Z      0:00.00 (soffice.bin)
 1121  ??  Z      0:00.00 (soffice.bin)
 1122  ??  Z      0:00.00 (soffice.bin)
 1123  ??  Z      0:00.00 (soffice.bin)
 1124  ??  Z      0:00.00 (soffice.bin)
 1125  ??  Z      0:00.00 (soffice.bin)
 1126  ??  Z      0:00.00 (soffice.bin)
 1127  ??  Z      0:00.00 (soffice.bin)
 1128  ??  Z      0:00.00 (soffice.bin)
 1129  ??  Z      0:00.00 (soffice.bin)

The only way to fix this is to either reboot (closing the xwindow is not enough, of course closing 
openoffice is not possible) or to kill -9 the suspended process.
Comment 1 terryt 2004-05-14 21:53:39 UTC
Added oooqa keyword.

I wasn't entirely clear what steps to use to reproduce the problem, but I did the following 
with OOo 1.1.1rc3 on Mac OS X 10.2.x :

1) Create New Text document.
2) Choose Tools -> Data Sources.
3) Click on New Data Source button.
4) Click OK to the default (JBDC) "Data Source 1" that is created.
5) Choose File -> Templates -> Address Book Source.
6) Click on Data Source popup menu, and choose "Data Source 1".
7) Dismiss any "The specified driver could not be loaded" Alert  that might appear.
8) Click on the Administrate button.
9) Observe OOo hangs as per user's report.

I saw all the zombie processes as well.

I will test with OOo 1.1.2fix2 when I get a chance.

So for the moment I am going to change the status to "New", as I can confirm the 
behaviour on a recent version of OOo.
Comment 2 khendricks 2004-05-19 14:30:46 UTC
Hi,

I just tested this on x86 Linux OOo 1.1.0, PPC Linux OOo 1.1.2fix2 and MacOSX OOo 1.1.2fix2.

The problem hang/crash with lots of zombies happens on *ALL* of those platforms.

To prevent this bug from being pushed back as only MacOSX Specific, I am changing the platform and 
OS to all.

Since the crash is very bad (no recovery, etc) this really should be a P2 issue!  But I will leave that up to 
the developer to determine.

Thanks for your bug report.

Kevin
Comment 3 terryt 2004-06-06 20:02:53 UTC
*** Issue 29880 has been marked as a duplicate of this issue. ***
Comment 4 marc.neumann 2005-02-11 11:15:21 UTC
Hi,

OOo 1.1.4 is out now, can you please have a look in the 1.1.4 version if the
issue still exists.

Bye Marc
Comment 5 rsussland 2005-02-11 17:21:36 UTC
Unfortunately I have a mac and 1.1.4 is not available for it yet.
Comment 6 marc.neumann 2005-02-14 08:24:52 UTC
Hi,

Oh that's bad. Anyway I close this issue now as "works for me".  

You can reopen this issue if you problem still exists in a *1.1.4* Mac build. 

Bye Marc
Comment 7 marc.neumann 2005-02-14 08:25:14 UTC
close