Issue 29363 - Outline numbering fails when template created from default in OOo1.1.1
Summary: Outline numbering fails when template created from default in OOo1.1.1
Status: CLOSED DUPLICATE of issue 27534
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1.1
Hardware: All All
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: openoffice
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-20 08:22 UTC by jeanweber
Modified: 2013-08-07 14:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Problem template created from OOo1.1.1 default (7.10 KB, application/vnd.sun.xml.writer)
2004-05-20 08:25 UTC, jeanweber
no flags Details
A template that works created from OOo1.0.3 default (8.42 KB, application/vnd.sun.xml.writer)
2004-05-20 08:26 UTC, jeanweber
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jeanweber 2004-05-20 08:22:26 UTC
1) If I open a document using File > New, using the default template that is 
supplied with OOo1.1.1, define paragraph styles to be used in outline numbering 
(instead of using the built-in Heading styles), set up outline numbering using 
those self-defined styles, and save everything as another template (I'll call it 
"Template-A", the numbering does not stick. That is, when I reopen Template-A, 
or create a document based on Template-A, tag paragraphs with the 
outline-numbered styles, save the file, close it and reopen it, the numbers are 
gone. The Outline Numbering dialog still lists the correct styles as being 
assigned to the correct outline level, but the numbers do not display.

2) As a test, I went back to OOo1.0.3 and opened a document using File > New, 
using the default template that was supplied with _OOo1.0.3_, and the document 
works fine -- retaining the outline numbers -- in both OOo1.0.3 and OOo1.1.1.

3) If I take a document created as in (1) above, which does not work in OOo1.1.
1, and open it in OOo1.0.3), the outline numbers reappear!

4) I repeated all this using OOo1.1.0 and it worked the same as for OOo1.0.3 -- 
as it should.

The problem appears to be something in the default that comes with OOo1.1.1. I 
will attach two files to demonstrate this problem.

Jean Weber
Comment 1 jeanweber 2004-05-20 08:25:05 UTC
Created attachment 15363 [details]
Problem template created from OOo1.1.1 default
Comment 2 jeanweber 2004-05-20 08:26:56 UTC
Created attachment 15364 [details]
A template that works created from OOo1.0.3 default
Comment 3 michael.ruess 2004-05-21 10:33:33 UTC
MRU->HBRINKM: That's true, though the styles are stored as Outline levels, from
the second level on, the outline numbering is missing here (in OO 1.1.x). Should
be fixed for OO 1.1.3 IMO.
For OO 2.0 it is a bit different, but I'll file a new issue for this.
Comment 4 rblackeagle 2004-05-22 12:30:24 UTC
This IS a regression and occurs in Master Documents as well -- outline numbering 
is not preserved in the template or in the saved MD.  In other words, it is a 
more general regression from 1.0.3.1 than simply in basic templates.
Comment 5 openoffice 2004-06-01 16:13:32 UTC
duplicate

*** This issue has been marked as a duplicate of 27534 ***
Comment 6 Mathias_Bauer 2007-02-05 13:57:18 UTC
going to close ancient issues
Comment 7 Mathias_Bauer 2007-02-05 14:10:22 UTC
closing ancient issues