Issue 30776 - Insert video
Summary: Insert video
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1.2
Hardware: PC Linux, all
: P3 Trivial with 6 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on:
Reported: 2004-06-27 17:10 UTC by m_aguilella
Modified: 2013-08-07 15:21 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description m_aguilella 2004-06-27 17:10:31 UTC
Inserting videos works fine in OpenOffice 1.1.0 (using plugger 5.x) but does not
 work in OpenOffice 1.1.2
Comment 1 wolframgarten 2004-06-28 09:51:45 UTC
Reassigned to msc. Please have a look. Thanks.
Comment 2 trelane 2004-07-20 00:29:25 UTC
I see this also (Linux, Pentium-M, Ximian OOo 1.1.2).

I insert an MPEG video with Insert->Object->Video.  A puzzle-piece logo appears,
about a quarter of which is occluded with a white-ish box.  OOo hangs.

Process tree:
solarion 22482     1  4 19:26 ?        00:00:05
/opt/Ximian-OpenOffice/program/soffice.bin private:factory/simpress
solarion 22513 22482  0 19:26 ?        00:00:00
/opt/Ximian-OpenOffice/program/getstyle-gnome --vcl-system-settings-window 56623108
solarion 22525 22482  0 19:27 ?        00:00:00 [pluginapp.bin] <defunct>
Comment 3 rvojta 2004-10-08 19:19:24 UTC
I'm trying to reproduce this with the latest build, but no success. 
OOo message is that this format is not supported ... 
Comment 4 zingale 2004-11-01 18:33:51 UTC
*** Issue 30776 has been confirmed by votes. ***
Comment 5 marc.neumann 2004-12-13 13:47:51 UTC
Hi m_aguilella ,

Can you please test this in the current developer build.
The current developer build can be found at
In this build we have change the media handling.

Thanks and bye Marc
Comment 6 schuetzm 2005-02-14 14:01:20 UTC
I'm getting the same here (SuSE 9.2, x86, OOo 1.1.4 from,
MozPlugger 1.7.1). Whenever I try to view a video, I only get a box which is
never redrawn. However, OOo neither hangs nor prints some kind of error message.
Viewing videos still worked in 1.1.1, and AFAIK also in 1.1.2, but not in later

I strace'd the whole thing, and it seems that although plugger is executed once
along with the plugins from pluginreg.dat, and sends its MIME-type list, it is
never executed to actually show the video.
Comment 7 schuetzm 2005-03-01 13:51:20 UTC
Although I have one working installation of OOo 1.1.2 on SuSE 8.2, I was unable
to make it work on SuSE 9.2.

Unfortunately I cannot try OOo 2.0bc, see

I also tried plugger-5.1.3 instead of mozplugger without getting any further.
Comment 8 schuetzm 2005-03-02 14:30:28 UTC
Tested with OOo 2.0bc, but still doesn't work.
Comment 9 zingale 2005-03-07 21:51:38 UTC
I can confirm that inserting movies in OOo 2.0bc under Linux is now working for
me, using the new JMF stuff.  I have confirmed this under both Redhat 8.0 and
Fedora Core 2, with an MPEG-1 movie.  Setting up the Java Media Framework is
quite a pain though, and more information should be given for this.  I submitted
my notes regarding this under issue 28163:

Comment 10 schuetzm 2005-03-14 13:26:44 UTC
Ok, I found the reason why it does not work for me: Plugger and MozPlugger both
send Mime-type lists that contain spaces after the separators. Fixing their
configuration files make MPlayer start up, but it's not showing
correctly/hanging (I guess this is unrelated to OOo).

Start of the output of pluginapp.bin

video/mpeg: mpeg, mpg, mpe: MPEG video;video/x-mpeg: mpeg, mpg, mpe: MPEG video

instead of

video/mpeg:mpeg,mpg,mpe:MPEG video;video/x-mpeg:mpeg,mpg,mpe:MPEG video

Unfortunately I do not know whether the NS Plugin Specification allows that. The
one at
doesn't make it clear. The best idea would probably be to filter out the spaces.
Comment 11 marc.neumann 2005-04-18 14:46:12 UTC
So, can I close this issue, because videos in the 2.0 works with the new JMF ?

Comment 12 schuetzm 2005-04-18 16:19:28 UTC
No, because this issue isn't directly related to videos, but to the plugin 
framework in general. Maybe it should be reassigned to component "Framework" 
Comment 13 marc.neumann 2005-05-23 14:51:52 UTC
set target to "Office Later" to get rid of the no target issues
Comment 14 marc.neumann 2005-06-09 15:03:40 UTC
reassign to issue pool