Issue 30890 - Folder lock not removed after closing file
Summary: Folder lock not removed after closing file
Status: CLOSED DUPLICATE of issue 21747
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 1.1.2
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords:
: 42580 (view as issue list)
Depends on:
Blocks:
 
Reported: 2004-06-29 20:50 UTC by deepcerulean
Modified: 2005-03-11 10:00 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description deepcerulean 2004-06-29 20:50:05 UTC
Forgive me if this is not the correct place to file this...but I couldn't find
anywhere else that seemed to fit.  I've created this problem with the drawing,
presentation and wordprocessor components (haven't tried it with the others).

Steps for recreating:
1. Create a new document
2. Save it to some folder (e.g. C:\blah\)
3. Close the application (but not Quickstarter)
4. Attempt to delete the folder

At this point you should receive a "Cannot remove folder, it's in use by someone
else" message.  Interestingly, you CAN remove the document you created...just
not the folder you put it in.  The folder remains locked until you exit OO.org
QuickStarter.

Further confounding things, when recreating this issue with the Presentation
component, the Folder lock wasn't released even after exiting OO.org QuickStarter.
Comment 1 treboscj 2004-07-01 03:55:04 UTC
This issue also happened to me. First on 1.1.1 then when I installed 1.1.2

I could reproduce it with the following : 
create a folder
create a new openoffice file OR copy an existing file to this folder
edit the document, save in this folder and exit
Trying to remove the folder was producing an error until quickstart is stopped

My problem is that during the tests with different components (drawing,
spreadsheet) the bug disapeared. I think I have been waiting (not doing that
manipulation) with quickstarter launched for a while (5 to 10 min).

But when I stopped quickstarter then the bug reappeared.
Comment 2 thorsten.martens 2004-08-06 11:40:35 UTC
This is a problem of the windows-system file-open/save-as dialog, which produces
a locking problem of the last opened folder. If OOo´s dialogs are used
(tools/options/OpenOffice/generell) these problems won´t occur. Not a OOo but a
Win OS problem.
Comment 3 thorsten.martens 2004-08-06 11:40:55 UTC
closed
Comment 4 lohmaier 2005-02-14 18:11:11 UTC
*** Issue 42580 has been marked as a duplicate of this issue. ***
Comment 5 flibby05 2005-03-11 09:59:47 UTC
this is already fixed, closing as duplicate of 21747
Comment 6 flibby05 2005-03-11 10:00:13 UTC
.

*** This issue has been marked as a duplicate of 21747 ***
Comment 7 flibby05 2005-03-11 10:00:34 UTC
.