Issue 30918 - Misaligned paste from web page table
Summary: Misaligned paste from web page table
Status: ACCEPTED
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 1.1.2
Hardware: All All
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-30 12:44 UTC by drc
Modified: 2017-05-20 11:13 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
code portion to be loaded with HTML Calc filter (17.23 KB, text/html)
2004-07-01 17:47 UTC, ooo
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description drc 2004-06-30 12:44:47 UTC
Open a new OOo spreadsheet

In a separate window browse with IE6 to 
http://www.onlineweather.com/v4/uk/climate/York.html

Highlight from Climate Guide for York, England down to ....require the SVG 
Plugin from Adobe.   Copy

Paste into spreadsheet with A0 selected

The word 'Month' and the month headings are offset to the right by one cell.
Comment 1 Regina Henschel 2004-06-30 21:06:29 UTC
It works fine for me with Mozilla and IE on Win98. Make sure, that you do not
mark the free line above the months, but start close to the text "month".
Comment 2 frank 2004-07-01 09:35:03 UTC
Hi Eike,

checked this Issue using IE6 and Mozilla1.7 on WinXP.

Pasting from IE results in a shifting of 1 cell to the right, Mozilla gives a
big merged cell in front of the Month, results looks really bad but is also just
one cell off.

Frank
Comment 3 Regina Henschel 2004-07-01 13:17:14 UTC
Have a look at the source of that site or open it in an OOo-HTML-Document. You 
see an empty cell, that is a "<td></td>" before the cell which has the text 
"Month". The problem is, how the browser handle empty cells when copying. My 
Opera 7.21 (on Win98) seems to ignores it and so "Month" is put into the first 
column in OOo-Calc. My Mozilla1.4 and IE6.0 (on Win98) seem to keep it and 
OOo-Calc puts "Month" into the second column. I think in that case OOo would be 
right to produce an empty cell in the first column.
Comment 4 ooo 2004-07-01 17:45:03 UTC
Regina is right, a cell is a cell, even if it's empty.. the "one big merged cell
with Mozilla", which also occurs on Solaris, may result from the sequence of
<hr><br><p> in which the first <table> is nested, didn't check though. I'm
taking this issue for just this reason, lowering priority to P4. As you never
know how long living a web site will be, I'll attach the relevant code portion
to this issue.
Comment 5 ooo 2004-07-01 17:47:59 UTC
Created attachment 16230 [details]
code portion to be loaded with HTML Calc filter
Comment 6 drc 2004-07-01 21:50:36 UTC
Apologies....

Since the selected areas comprises two distinct tables there is no logical 
alignment between the month headings and the table body.  So the concept of 
misalignment is spurious.

I recommend the issue be closed as invalid.

It's a pity the UK government uses that web page as an example of material 12 
year old pupils should be able to chart by pasting it into a spreadsheet!
Comment 7 Marcus 2017-05-20 11:13:49 UTC
Reset assigne to the default "issues@openoffice.apache.org".