Issue 31053 - please support https, too
Summary: please support https, too
Status: CLOSED FIXED
Alias: None
Product: ucb
Classification: Code
Component: code (show other issues)
Version: OOo 1.1.2
Hardware: Other All
: P3 Trivial with 4 votes (vote)
Target Milestone: OOo 2.4
Assignee: thorsten.martens
QA Contact: issues@ucb
URL:
Keywords:
: 32935 40283 (view as issue list)
Depends on:
Blocks:
 
Reported: 2004-07-03 01:03 UTC by rene
Modified: 2009-04-28 09:10 UTC (History)
4 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description rene 2004-07-03 01:03:58 UTC
Hi,

we received in the Debian BTS a wish for OOo to support https, too as it does
now for http (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=244280).

I foward it to you here :-)

Regards,

René
Comment 1 matthias.huetsch 2004-07-05 11:23:12 UTC
Hi Kai,

I seem to remember that we once discussed this, but don't remember the outcome.
Can you please look into this, again, and comment on it?

Thanks,
Matthias
Comment 2 kai.sommerfeld 2004-07-27 16:43:41 UTC
Sorry, due to limited resourcs it is not planned to implement https support in
the OOo 2.0 timeframe.
Comment 3 Mathias_Bauer 2005-01-12 12:30:10 UTC
*** Issue 40283 has been marked as a duplicate of this issue. ***
Comment 4 kai.sommerfeld 2005-12-05 15:32:11 UTC
Andreas, please take care of this feature.
Comment 5 andreas.bille 2006-05-24 17:26:33 UTC
accepted
Comment 6 andreas.bille 2006-06-14 10:44:52 UTC
accepted
Comment 7 andreas.bille 2007-04-03 16:02:33 UTC
ABI->KSO: As discussed ...
Comment 8 andreas.bille 2007-04-03 16:08:23 UTC
ABI->KSO: As discussed ...
Comment 9 kai.sommerfeld 2007-04-05 08:11:22 UTC
.
Comment 10 kai.sommerfeld 2007-08-15 12:35:50 UTC
KSO->TKR: Please take care of this issue.
Comment 11 tkr 2007-08-16 08:39:37 UTC
.
Comment 12 tkr 2007-09-06 14:06:49 UTC
*** Issue 32935 has been marked as a duplicate of this issue. ***
Comment 13 kai.sommerfeld 2007-09-25 09:50:28 UTC
*** Issue 72021 has been marked as a duplicate of this issue. ***
Comment 14 rene 2007-10-05 13:19:41 UTC
tkr: why openssl (BSD, and has some problems with GPLed stuff which probably can
affect GPLed extensions?) instead of GnuTLS? (LGPL, except GNUTLS-EXTRA which is
GPL, but we don't need to use that and if it causes problems for the source we
can remove this part?)?

I think there should be a choice between OpenSSL and GNUTLS... (the neon in
Debian has a flavour built with gnutls, which I'll probably switch to - didn't
notice till a few days ago)
Comment 15 tkr 2007-10-08 14:48:58 UTC
I don't see any problem if you want to build NEON against GNUTLS instead of
OpenSSL and link it with OOo.

At the moment we only use OpenSSL with NEON, so you can replace it with GNUTLS
with no side effects, i guess.

Openssl is older and more widely used. Thats the root cause why we chose this one.



 
Comment 16 tkr 2007-10-22 08:09:04 UTC
ready for qa
Comment 17 tkr 2007-10-22 08:10:27 UTC
tkr->rt: please take care of this issue
Comment 18 rt 2007-11-01 10:34:48 UTC
Please verify on CWS tkr05.
Comment 19 thorsten.martens 2007-11-06 10:41:24 UTC
checked and verified in cws tkr05 -> OK !
Comment 20 thorsten.martens 2009-04-28 09:10:50 UTC
closed