Issue 31621 - RTF: Loop with 3rd party (?) RTF code
Summary: RTF: Loop with 3rd party (?) RTF code
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 680m47
Hardware: PC Windows XP
: P2 Trivial (vote)
Target Milestone: ---
Assignee: openoffice
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-07-17 05:57 UTC by kasey
Modified: 2013-08-07 14:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
. (44.59 KB, text/rtf)
2004-07-17 06:00 UTC, kasey
no flags Details
Screenshots of test case (138.27 KB, application/x-compressed)
2006-09-11 16:59 UTC, tmjura
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kasey 2004-07-17 05:57:56 UTC
This RTF file crashes 680m47 and 680m41 but not Hakone. It has been obtained
from www.esa.doc.gov/Word/Final%20ESA%20guidelines.doc .
Comment 1 kasey 2004-07-17 06:00:27 UTC
Created attachment 16529 [details]
.
Comment 2 michael.ruess 2004-07-19 15:51:11 UTC
MRU->MM: This was good in OO 1.1.x, but loops in 680 at about 15% of progress.
Seems to be older or 3rd party RTF dialect; when saving a new instance of the
file with Word 2003, it can be imported pretty good.
Comment 3 andreas.martens 2004-12-01 16:03:06 UTC
ama -> flr: Please have a look.
Comment 4 Mathias_Bauer 2006-08-30 15:16:34 UTC
reassigning to hbrinkm
Comment 5 tmjura 2006-09-11 16:58:31 UTC
1. Open document "gov.doc.436.doc" in Word 2002 (10.6802.6735) SP 3
2. NO problem
3. close Word 2002 (10.6802.6735) SP 3

4. Open document "gov.doc.436.doc" in OpenOffice 2.0.3 Quicklaunch
(- I don´t know if "Quicklaunch" is correct translation - anyway)

5. OpenOffice 2.0.3 HALTS and progress bar is shown down
=> (screenshot A1.png)

6. close OpenOffice 2.0.3 
7. QUESTION: OpenOffice 2.0.3 is closed ??

8. Open document "gov.doc.436.doc" in Word 2002 (10.6802.6735) SP 3
9. PROBLEM: document "gov.doc.436.doc" is locked
=> (screenshot A2.png)
10. Press CANCEL in dialog that is seen.
11. close Word 2002 (10.6802.6735) SP 3


=> SEPARATE: REPEATING PHASES
  11.1.  Open "gov.doc.436.doc" again from Quicklaunch in OpenOffice 2.0.3
  11.2. Same result: HALT
  11.3. close OpenOffice 2.0.3 
=> SEPARATE: REPEATING PHASES


12. Open Task Manager
13. END PROCESS "soffice.exe"
14. Quicklaunch icon remained, but will disappear when the mouse is moved on it

=> SEPARATE: START
  At some point there were two QuickLaunch icons - try to repeat
   14.1. Quicklaunch icon remained, 
   14.2. don´t move the mouse is moved on Quicklaunch icon
   14.3. Open OpenOffice 2.0.3 => Writer from Windows start menu
   14.4. IS REPEATABLE (screenshot A4.png)
   14.5. move mouse on QuickLaunch icons
   14.6. the other QuickLaunch icon will disappear
=> SEPARATE: END

15. Open document "gov.doc.436.doc" in Word 2002 (10.6802.6735) SP 3
16. NO problem
17. close Word 2002 (10.6802.6735) SP 3

18. Open document "gov.doc.436.doc" in OpenOffice 2.0.3 => Writer from Windows 
start menu
19. PROBLEM: trying to recover something
=> (screenshot A3.png, in FInnish - sorry about that)
20. PRESS OK.
21. Empty document is "recovered"
22. close OpenOffice 2.0.3 

23. RANDOMIZED FEATURE ?
- in repeat testS the recovery dialog "A3.png" was not seen again


REPEATABLE - was repeated
one phase NOT repeated, but screenshot is

OS used:
WIN XP Professional version 2002 SP 2 + some automatic updates
Comment 6 tmjura 2006-09-11 16:59:51 UTC
Created attachment 39087 [details]
Screenshots of test case
Comment 7 tmjura 2009-08-11 13:22:08 UTC
Hi all,

I opened the document with 3.1.0.
It seemed to work.

Somebody could check this, and close issue, if possible.


Test 1: opened without problem in 3.1.0.

TEST 1 info:
- WIN XP SP 2 + latest updates
- OOo 3.1.0
- OOO310m11
- build 9399
- Finnish Language Pack: OOo_3.1.0rc2_20090427_Win32Intel_langpack_fi.exe


Test 2: opened without problem in 3.1.0.

TEST 2 info
- PCLinuxOS LXDE.2009.4
- OOo 3.1.0
- OOO310m11
- build 9399
- there is also mentioned that Build 3.1.0.5
- Finnish OpenOffice
- updates by PCLinuxOS package manager.


Test 3:
- Problems, problems, 2.4.1.
- crashed, etc.

TEST 3 info:
- Debian 5
- OOo 2.4.1
- open-office.core. 1:24.1+dfsg-1
- Wed Mar 25 21:25:25 UTC 2009
- Finnish OpenOffice
- updates by package manager.


Somebody could check this, and close issue, if possible.


Regards,

tmjura
Comment 8 openoffice 2009-08-12 13:06:20 UTC
checked on DEV300_m54: works for me
Comment 9 openoffice 2009-08-12 13:06:40 UTC
closed