Issue 3166 - Conversion errors, Word to OOo
Summary: Conversion errors, Word to OOo
Status: CLOSED WONT_FIX
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 641
Hardware: PC Windows NT
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-02-21 15:11 UTC by aelfgifu
Modified: 2003-09-08 16:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
conversion problems from Word to OOo, comments in *red* inside (258.24 KB, application/octet-stream)
2002-02-21 15:12 UTC, aelfgifu
no flags Details
Original Word file (824.00 KB, application/octet-stream)
2002-03-05 09:45 UTC, aelfgifu
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description aelfgifu 2002-02-21 15:11:09 UTC
See attached file, converted from a Word dot file specially trimmed down to be 
as simple as poss. (eg., to have few section breaks, simple page numbering) 
etc., whilst still retaining the corporate look & feel. My comments are in RED. 
BTW, files like this regularly crash with an unrecoverable error.  

1. Graphics lost or misaligned in headers
2. 'Title' variable converted but loses value.
3. User-defined variables not converted but text value remains.
4. Table of contents formatting incorrect
5. List Bullet and List Number style nearly converted correctly but badly 
spaced & given new style name. 
6. Body Text style name changed to Text Body. Should have option of keeping 
original style names.

Having said all that, the conversion is really quite good -- font effects, 
paragraph styles, tables etc. all come over very nicely. It would not be 
onerous to tidy up a *few* documents like this; the problem is that there are 
dozens of really large ones. And there are similar problems on the Word side if 
I convert from OOo to Word, and that will happen frequently. I'd be like 
Sisyphus, forever rolling that rock up the hill.
Comment 1 aelfgifu 2002-02-21 15:12:23 UTC
Created attachment 1077 [details]
conversion problems from Word to OOo, comments in *red* inside
Comment 2 stefan.baltzer 2002-02-22 13:17:29 UTC
Reassigned to Michael.
Comment 3 michael.ruess 2002-02-25 15:30:49 UTC
Please attach the original Word document to this issue. Without it we
won't be able to work on this problem, because we need the reference
what the content of the document should look like.
Comment 4 aelfgifu 2002-03-05 09:45:45 UTC
Created attachment 1149 [details]
Original Word file
Comment 5 michael.ruess 2002-05-07 09:21:48 UTC
Reopened.
Comment 6 aelfgifu 2002-11-21 13:58:18 UTC
see also enhancement request: 3070
Comment 7 michael.ruess 2002-11-25 15:24:51 UTC
As long as this is a collection of problems, for the future please
note that you only submit one problem per issue. It makes handling &
bugfixing much easier.
Comment 8 michael.ruess 2002-11-25 15:55:46 UTC
To your problems:
1) The "lost" graphic in header: at the moment Writer is not able to
display graphics outside a header when they are anchored inside the
header. This was never planned but there are dicussions to enhance
Writers capabilities for compatibility.

2) Title variable import is fixed with OpenOffice 643.

3) This kind of user defined variables is not converted because there
does not exist a correspondant feature in Writer. Please submit an
"Enhancement" issue if you are interested in such fields in Writer.

4) Because of a different handling of TOC's in Writer and Word, it is
not possible to import formatting by 100%. E.g. we have to go without
additional tabs when importing.

5) I can see the problem. I don't know, if we could catch it. I will
file an internal task and we'll look for a solution at least for
OpenOffice 644.

6) "Body Text" is a style from the standard style pool in Word. "Text
body" is correspondant style in Writer and also is a standard style.
So on import it is mapped to "Text body".

You see, that there are some issue which we are not able to fix in the
filter. Additional features have to be implemented in Writer to have a
better representation in OO Writer.
Comment 9 michael.ruess 2002-11-26 16:14:58 UTC
Filed internal Task for wrong distance. Fix headed for OpenOffice 644.