Issue 31980 - autocomplete function corrupted with diacritical symbols
Summary: autocomplete function corrupted with diacritical symbols
Status: CLOSED DUPLICATE of issue 27051
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 680m47
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: Oliver Specht
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-07-23 10:37 UTC by tuharsky
Modified: 2013-08-07 14:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
I type "tla" (276 bytes, image/png)
2004-07-23 10:38 UTC, tuharsky
no flags Details
I continue with "Ä" and woala -it "autocompleted" immediately, but the word should be "tlaÄiareň". If I continue typing, it has no effect on the word, the letters are simply added. (356 bytes, image/png)
2004-07-23 10:41 UTC, tuharsky
no flags Details
I type "tla" (276 bytes, image/png)
2004-07-23 10:43 UTC, tuharsky
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description tuharsky 2004-07-23 10:37:19 UTC
I edited table in Writer. While typing some words into cells, the autocomplete
acted this way:
as soon as it found any similar word, it immediately "completed" the word I was
typing. It even didn't include the last letter (the one that started the
"completion") into the "completed" word, often the letter was nowhere!

The "autocomplete" than dosen't take in decision any other letters. As soon as
it inserts his kinda "completion", he stops autocomplete function and considers
the word "complete".

It seems, that only diacritical letters start the autocompletion madness.
Comment 1 tuharsky 2004-07-23 10:38:07 UTC
Created attachment 16697 [details]
I type "tla"
Comment 2 tuharsky 2004-07-23 10:41:24 UTC
Created attachment 16698 [details]
I continue with "Ä" and woala -it "autocompleted" immediately, but the word should be "tlaÄiareň". If I continue typing, it has no effect on the word, the letters are simply added.
Comment 3 tuharsky 2004-07-23 10:42:48 UTC
Should I mention, that I see no other problems with diacritical letters. Out of
autocompletion, they work just normally.
Comment 4 tuharsky 2004-07-23 10:43:13 UTC
Created attachment 16699 [details]
I type "tla"
Comment 5 michael.ruess 2004-07-23 10:47:56 UTC
reassigned to SBA.
Comment 6 tuharsky 2004-07-23 11:56:12 UTC
The bug is not limited to table, appears in regular text too.
Comment 7 stefan.baltzer 2004-07-26 13:17:10 UTC
SBA->OS: Probably duplicate of issue 27051. Reassigned to OS.
Comment 8 immanuelcrc 2004-08-03 03:07:52 UTC
I don't know what diacritical characters are, but I think I am also getting this
with apostrophes.

Type in we've in a document. Verify that it is in your list of autocompletion
words. Then type in we' and the word become weve without any enter to accept the
word. If you delete the we've entry in the autocompletion, the next time you
type we're it is okay, but then it gets re-added to your list and bingo, the
next time you've got weve with only typing we'

I am also posting this on issue 27051.

680m47 on Gentoo 2004.1 

Comment 9 olivierblanc 2004-08-03 17:43:07 UTC
I am getting the same while typing in french.
for exemple : i am tying to type "deuxième" (second in english)
typing "deux" will propose the word deux[ième]. While I am continuing to type
the i and the è, it will then automatically complete the word to "deuxime"
(removing the beatifull è (&egrav;)

I am using version  1.9.m47 on Linux (mandrake 10.0)
Comment 10 stefan.baltzer 2005-06-30 16:59:38 UTC
SBA: PL assured me that this is the same root cause as issue 27051 (with target
OOo 2.0).
There is a workaround:
In a terminal, type "setenv USE_XOPENIM true" before launching the office from
there.

*** This issue has been marked as a duplicate of 27051 ***
Comment 11 stefan.baltzer 2005-06-30 17:02:12 UTC
SBA: The workaround I mentioned above is for Solaris Sparc.

On LINUX,  type "export USE_XOPENIM true" before launching the office from there.

Closed.